SAP Knowledge Base Article - Public

2543362 - Search on Sub-Territories Includes Wrong Data

Symptom

The Account advanced search on sub-territories includes wrong data when a territory name matches with another territory's ID.

Reproducing the Issue

  1. Go to Customers work center.
  2. Go to Accounts view.
  3. Click on Advanced Search button.
  4. Under Team --> Territory search for territory XXX (XXX represents the ID of the territory).
  5. Check the box Include Sub-Territories.
  6. Advanced search with sub-territory includes wrong data. It includes territory that name matches with another territory's ID, however, it's not a sub-territory of XXX.

Cause

As this is an identifier field, whatever is typed in this field it will search against both ID and description.

Resolution

This is the system expected behavior.

You can find more details about the services offered by Cloud Service Center on https://www.sap.com/services/application-development.html . You can contact Cloud Service Center as follows:

  1. If you are a partner: please use cloudsolutionpartner@sap.com or the Partnerfinder
  2. If you are a customer: please use the little blue box “Contact Us” shown on the very right hand side of https://www.sap.com/services/application-development.html, choose “Contact Us”, choose “Services”, choose “SAP Custom Development” and complete the page.

An alternative option may be to check the SAP Hybris Cloud for Customer Ideas Forum to submit an idea: https://influence.sap.com/SAPCloudforCustomer

Keywords

KBA , LOD-CRM , Cloud for Customer , How To

Product

SAP Cloud for Customer 1802 ; SAP Hybris Cloud for Customer 1708 ; SAP Hybris Cloud for Customer 1711