2543200 - Outlook Server-Side Integration: Client-Side Add-in Doesn't load in Outlook [Invisible Solution ] - Troubleshooting Steps

SAP Knowledge Base Article - Public

2543200 - Outlook Server-Side Integration: Client-Side Add-in Doesn't load in Outlook [Invisible Solution ] - Troubleshooting Steps

Symptom

You have setup the server-side Integration for Outlook C4C but the Add-in button in Outlook is greyed-out.

Reproducing the Issue

[ Pre-requisites:

  • You have licensed your system to use Server-side Integration for MS Outlook.
  • You have provisionned Key Users to activate business Users
  • You have followed the documentation and setup Server-side integration in your system. ]

Steps:

  1. Go to Outlook.
  2. In the Home tab the View Context of SAP Hybris Cloud for Customer button is greyed-out:

.2017-10-03_15-30-41.png

Cause

There might be several reasons why the Add-in is grayed-out. Please follow the troubleshooting steps below.

Resolution

Instructions

a) Make sure the add-in is installed by verifying its status in C4C:

  1. Go to Email Integration
  2. In the Groupware Settings select Users.
  3. Find the affected user and press the gear icon on the top right.
  4. Press Check Add-in status.

001.png

b) Result should be the following:

002.png

c)  Log-on to the OWA Exchange server or open the Office 365 account in a webbrowser. Make sure the add-in is loading successfully.

003.png

 

  1. If add-in works in OWA, but doesn't load in Outlook - check the current Outlook version and make sure the most recent updates are installed. Refer to additional information on Microsoft page about versions http://social.technet.microsoft.com/wiki/contents/articles/31133.outlook-and-outlook-for-mac-update-file-versions.aspx#A.
  2. Try installing any other free add-in from Office store and check, if it works.
  3. Sometimes changes to add-in commands, such as the icon for a ribbon button or the text of a menu item do not seem to take effect. Clear the Office cache of the old versions. Delete the contant of folder %LocalAppData%\Microsoft\Office\15.0\WEF (for Office 2016 it would be 16.0) and restart Outlook.
  4. Internet Explorer security settings might also be related to the issue (if add-in fails to load). Steps to proceed:
    1. In Internet Explorer, click the Tools button, and then click Internet Options.
    2. Click the Security tab, and then select the Internet Sites Zone.
    3. Select the Enable Protected Mode check box, and then click OK.
    4. Restart Internet Explorer and Outlook, check if the issue perisists.
    5. If it didn't work, enable Protected mode on Restricted Zone and try.

Keywords

KBA , LOD-CRM , Cloud for Customer , How To

Product

SAP Hybris Cloud for Customer all versions