SAP Knowledge Base Article - Public

2542140 - Users do not Have Access to Report - Canvas - username conflict

Symptom

  • A user has been granted access to Report Center and has the required functional permissions.
  • But it is unable to create / access  'Report - Canvas' reports

Environment

SAP SuccessFactors HXM Suite

Reproducing the Issue

  1. Create two users in BizX with the same UserID but with different letter casing.
    example: SFADMIN and sfadmin
  2. Create a new permission role and grant Report Center permissions and all functional permissions required for Report Canvas to it.
  3. Assign the role to a new permission group and add SFADMIN and sfadmin to this group.
  4. Log in to the instance as SFADMIN and access Report Center.
  5. Try creating a new 'Report Canvas' report or try accessing an existing 'Report Canvas' report - Works fine.
  6. Log in as sfadmin and access Report Center.
  7. sfadmin will not be able to create to access 'Report Canvas' reports in spite of having the same permissions as SFADMIN

Cause

Canvas reports uses its own User / Permission structure, replicated from BizX for the most part.

The username naming convention in ORD is case insensitive.
When a second user with the same UserID but different letter casing (SFADMIN vs sfadmin), requests for 'Report Canvas' reports, ORD assumes this is a duplicate and rejects the request.

Resolution

If two users have the same UserID in BizX even if with different letter casing, the second user will never be able to create / access 'Report Canvas' reports in Report Center.
The second user's UserID has to be changed.

See Also

Other possible causes and fixes: 2796673 - Report Canvas is unavailable in Report Center

Keywords

Canvas, Report, missing, not, appearing, user, unable, able, create, report, ord, Online Report, Designer, Analytics, Center, error, username , KBA , LOD-SF-ANA-RCT , Report Centre , LOD-SF-ANA-ORD , Online Report Designer , Problem

Product

SAP SuccessFactors HCM all versions