SAP Knowledge Base Article - Public

2541866 - Download Search Results for Background Jobs shows incorrect time

Symptom

  • Start Date, End Time and Submitted Time are showing several hours off in Download Search Results for Background Job search results
  • The download shows the correct timezone, but the time does not match the search results in the LMS

Environment

SAP SuccessFactors Learning Management System (LMS)

Reproducing the Issue

  1. Login to LMS Admin
  2. Navigate to System Admin > Background Jobs
  3. Run a Search and include the fields for Start, End and/or Submitted Date/Times
  4. Note the times display correctly in the Admin User's timezone preference
    SearchResults_TZ.jpg
  5. Click "Download Search Results"
  6. Open the downloaded .csv
  7. Note the time is in UTC yet still shows the Admin User's timezone, which is incorrect
    SearchResults-Download_TZ.jpg

Note: Other search results, such as for Scheduled Offerings, shows the correct time

Cause

This has been raised to Product Engineering for further investigation under LRN-24464

Resolution

This issue has been corrected in release b1802

Keywords

SF SuccessFactors LMS Learning Background BG jobs search download export result csv time datetime UTC timezone zone incorrect wrong match mismatch not correct , KBA , LOD-SF-LMS-BCJ , LMS Background Jobs , LOD-SF-LMS , SuccessFactors Learning , LOD-SF-LMS-ADM , Admin Tools , Bug Filed

Product

SAP SuccessFactors Learning 1708