SAP Knowledge Base Article - Public

2538339 - How the Target Group Member's E-Mail and Phone Number Check Works

Symptom

How the Target Group Member's E-Mail and Phone Number check works.

Reproducing the Issue

  1. Go to the Sales Campaign work center.
  2. Go to the Target Group view and search for Target Group ABC (where ABC is the Target Group name).
  3. Open Target Group ABC and go to the Members facet.
  4. Select the Member and click on action Check E-Mail Address.

An error as E-mail address of N members is missing is trigger (where N is number of members for which E-mail is missing).

If you see the column name Addressability , for those N members the value under the column will be Not Ok.

Cause

The E-mail address is missing in the Account/Contact (Business Partner) master data.

Resolution

  1. Go to the Sales Campaign work center.
  2. Go to the Target Group view and search for Target Group ABC .
  3. Open Target Group ABC and go to the Members facet.
  4. Select one of the Member (For e.g. Account LMN ,where LMN is account name) where Addressability column is showing the value as Not Ok on E-mail address check.
  5. In the Account LMN header maintain the E-mail address and Save the changes.
  6. Now go back to the Target Group ABC's Members facet and again perform action Check E-mail address.

Now for Member LMN the Addressibility column will have value as OK and error message will be only for N-1 members only.Same apply for Phone Number check.

Keywords

KBA , SRD-MD-PRD-PRD , Product , How To

Product

SAP C4C CORE all versions ; SAP Cloud for Customer all versions