SAP Knowledge Base Article - Public

2529515 - Position To Job Information Sync Troubleshooting Guide (PositionToJobInfoSyncRuleCheck) - EC

Symptom

The Position to Job Information Sync for the Position's incumbent is not occurring in SuccessFactors Employee Central.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

The behavior occurs in the following scenarios:

  • Position changes via "Edit" mode on the Position in the "Position Org Chart".
  • Position Changes via Import.
  • Assigning a position to a new hire in the Add New Employee Wizard.
  • The position assignment of the employee changes via "Change Job and Compensation Info" Manager Self-Service (MSS) action.
  • Mass Data management for Position (uses import framework).

Cause

A configuration issue, or incorrect understanding of the scenarios in which a Position to Job Information Sync for the Positions incumbent will occur, is at fault.

Resolution

  • Position Management, especially in relation to the Position to Job Infomation Synchronization, has specific configuration requirements, along with specific scenarios for when the Position to Job Information Sync will occur.
  • If the configuration is correct and you are triggering the Position to Job Information Sync in a supported scenario, the Job Information of the Position Incumbent will be updated according to your setting and Position to Job Information Sync Rule.

If you are experiencing an issue whereby, your Position to Job Information Synchronization is not working correctly or at all, it is recommended to review your configuration and the supported scenarios, in the following three areas, to resolve your issue: 

General Configuration Issues

Position Management Settings:

  • Please make sure your Position To Job Information Sync rule is triggered correctly. This rule should ONLY be triggered in the following two places only:

    • The "Rule for Synchronizing Position to Job Information" field on the "Synchronization" tab of the "Position Management Settings" UI in Admin Center.
    • onChange on the Position HRIS field in Job Information, from "Manage Business Configuration".
       
  • Please make sure that the correct option is selected for the "Position Organizational Chart Synchronization"  field on the "Synchronization" tab of the "Position Management Settings" UI in Admin Center.
  • You can use this option to determine whether and how the synchronization of position matrix relationships and job relationships is executed.
  • The possible options are:

    • Never - If you choose this, no synchronization takes place.
    • User Decision - If you choose this, a popup appears after every position change asking whether the incumbents should be synchronized.
    • User Decision If Required - If you choose this, a popup appears, but only if the position and incumbents are not in sync.
    • Automatic -If you choose this, synchronization takes place in the background.

Object Definition Settings: 

  • When using Workflows on Position changes, you need to set "Pending Data" field on the Position Object Definition to "Yes". See KB article 2462394 - Position to Job Info sync does not work if Position Workflow is assigned
  • The "Incumbent" field should have "Visibility" be set to "Not Visible". This field is not to be used in Position Management. This field is only used for Succession Management.

Rule Configuration Issues

Rule Trigger:

  • The rule should be created using the "Synchronize Position Changes to Incumbents" option provided on the "Create New Rule" screen in "Configure Business Rules". This creates the rule with the correct base object "Job Information". No other "Parameters" should be added to this rule. 

Rule IF Conditions:

  • The rule should only be triggered if a position is assigned to the job info, this is done through the IF- Condition of the rule, which must check if the Job Information Position is not equal to Null. 
  • This rule should NEVER be Always True
  • You can only make this selection if the rule for synchronizing position to job information does not include ELSE or ELSEIF statements. See Here

Rule Set Conditions:

  • The supervisor is set automatically based on the leading hierarchy and should NEVER be set by the sync rule.  
  • The Matrix Realtionships/ Job Relationships should not be included in the rule. If you would like to sync Matrix Relationships to Job Realtionships then please review KB article 2306515 - Position Management: Position Matrix Relationship to Job Relationship Sync Troubleshooting Guide 
  • The Position should always be referenced in the drill-down on the right-hand condition of the "Set" statement. Set Job Information. Job Title to be equal to job Information. Position. Job Title 
  • Company/Legal Entity should only be mapped via the rule, if "Use Company Filter for Positions in MSS Job Information and History" option is set to "No" on the "UI Customizing" tab of the "Position Management Settings" UI in Admin Center. See KB article 2386613 - When can you include Company/Legal Entity in the Position to Job Information Sync Rule. 
  • The "Incumbent" field should never be mapped via the rule. This field is not to be used in Position Management. 
  • If you use Object Associations, that is have Parent Child Relationships defined between Objects, then corresponding fields need to map to respect the order of the associations. See KB article 2511104 - Position to Job Information Synchronization Rule, Field Mapping Order. 
  • Note: field criteria needs to be added to the Position Fields along with the Job Information fields to fully respect the Associations. Refer to KB article 2172234 - Association not working while creating a Position

Scenarios in which the Position Change will sync to the Job Information of the Incumbent, if the above configuration is correctly defined

UI Changes:

  • As of b1905, changes made to a Position with an incumbent, will trigger the Position to Job Information Sync (based on the configuration), when the changes are carried out via "Edit" and "Manage" mode in the Position Org Chart, along with changes made via Manage Positions. 
  • Change made to the Position with an Incumbent, from Manage Data will NEVER trigger the Position to Job information Sync. 
  • Deletion of a Position or Job Information record will never trigger the Position to Job information Sync or vica versa. IF you manually delete the record from the Position you will need to manually delete the record from Job Information also.
  • The Position to Job Information Sync rule should trigger on Change of the Position field from Job Information and the Hire Wizards.

Imported: 

  • If you want to trigger synchronization when you're importing positions, add the technicalParameters column to your position import file.
    Enter “SYNC ” as the value for the technicalParameters column for those position records that are to trigger a synchronization to the jobInfo object.
  • The synchronization is carried out on the effective start date of the corresponding position record. See KB article 2409912 - What Values are Supported in the "technicalParameters" Field to trigger a Position to Job Information Sync 
  • The Position to Job Information Sync, will only occur on Job History Imports if you are using the following feature, which can be enabled from >Admin Center > Company, System and Logo Settings: "Enable rules execution during Job Information and (GA)Termination import"
  • API Upserts won't carry the sync, please review: Employee Central Position Management - Define Synchronization Position to JobInfo
  • SPECIAL NOTE: In the 1802 release, the switch for Enable rules execution during Job Information and (GA) Termination Import is moved from Company System and Logo Settings to Role-Based Permissions. See KB article 2615455 - Job Information: Rule and Propagation on Import switches now migrated to Role-Based Permissions from Company System and Logo Settings

System Behavior

  • If you make changes to the position (from one of the above supported methods), which include field changes and a change to the Higher-Level Position. Two records will be created in the Job History of the Incumbent. One for the field changes as defined in the sync rule and one for the Supervisor change. Refer to KB article 2287203 - Two Job Information records being created by Position to Job Info sync with change in a Position attribute and Reports to (Higher Level Position) field

FAQ - Additional Information

Q) Where can I get Guide?

A) Guide: Employee Central Position Management

Chapter: Synchronization

Q) Does the position to job information sync respect RPB?

A) Yes

See Also

  • 2306515 - Position Management: Position Matrix Relationship to Job Relationship Sync Troubleshooting Guide
  • 2615455 - Job Information: Rule and Propagation on Import switches now migrated to Role-Based Permissions from Company System and Logo Settings
  • 2318852 - Employee Central - Position Management

Keywords

SF SuccessFactors EC Pos2Job, Position, Job information, Sync, Position management settings, Position to Job Information Sync, check tool , KBA , LOD-SF-EC-POS , Position Management , LOD-SF-EC-HRS , HRIS Sync , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM all versions