SAP Knowledge Base Article - Public

2523071 - Supervisor is unable to approve user's registration

Symptom

  • When a supervisor tries to approve a scheduled offering registration for a user who was booked through a group.
  • The error is: "The maximum enrollment for the scheduled offering has been reached"

Environment

  • SAP HCM suite
  • SuccessFactors
  • Learning Management System (LMS)
  • Supervisor interface > My employees > Approvals

Reproducing the Issue

  1. Create a scheduled offering with a max registration of X and with approval required and a price
  2. Create a group slot that matches X
  3. As a supervisor, enroll a user in the scheduled offering
  4. As a supervisor, try to approve the enrollment
  5. You cannot approve: "The maximum enrollment for the scheduled offering has been reached"

Cause

The Slot ID is not passed to further screens in the approval wizards. So on the final screen schedule offering maximum registration validation is applied on this use-case scenario.
Slots are already preregistered seats and this max registration validation is not required.

Resolution

The issue will be fixed in 1711.

Workaround:
in the scheduled offering summary > View All > set "enable users to waitlist" to YES. This will allow the supervisor to approve the request and the users will be enrolled (not waitlisted).

Keywords

SAP, Successfactors, Learning, LMS, approvals, registration, scheduled offering, "The maximum enrollment for the scheduled offering has been reached", "enable users to waitlist" , KBA , LOD-SF-LMS-ADM , Admin Tools , LOD-SF-LMS , SuccessFactors Learning , Bug Filed

Product

SAP SuccessFactors HCM Core 1705