2522762 - Some users are seeing the wrong content when launching a course in the LMS.

SAP Knowledge Base Article - Public

2522762 - Some users are seeing the wrong content when launching a course in the LMS.

Symptom

When we launch a course in the LMS, sometimes it plays the correct course and other times it plays an incorrect content.

Environment

All SAP SuccessFactors Learning Management System (LMS) versions

Reproducing the Issue

1) Login as a user in the LMS
2) Launch a course

Cause

The behavior described can be caused when importing multiple courses in the same content folder. In other words, your Production and Staging LMS environments may place content files for different courses in the same folder when the two conditions below are met:

1) Your LMS environments are using the same deployment location folders (ex. /prod/) AND
2) There was no content package ID given during the content import, so the Production and Staging LMS environments ended up choosing the same ID for different courses.

Resolution

Our advice is to change the Deployment Location folder so that your Production LMS is importing content files into one folder (ex. /prod) and your Staging LMS is importing into a different folder (ex. /stage/). Please see below for reference:

Stage:
DeploymentLocation_stageFolder.png

Production:
DeploymentLocation_prodFolder.png

See Also

2075253 - How to reassign content (not the item) to users - via the Content Reassignment wizard

Keywords

SF SuccessFactors LMS Learning Wrong content
Incorrect content
Different content
Wrong course
Incorrect course
Different course , KBA , LOD-SF-LMS-CNT , Content , Problem

Product

SAP SuccessFactors Learning all versions

Attachments

DeploymentLocation_prodFolder.png
DeploymentLocation_stageFolder.png