2521446 - Error: 'HY000:INVALID_FIELD' when refreshing a report based off Salesforce.com Command Object in Crystal Reports

SAP Knowledge Base Article - Public

2521446 - Error: 'HY000:INVALID_FIELD' when refreshing a report based off Salesforce.com Command Object in Crystal Reports

Symptom

  • Error: 'INVALID_FIELD'
  • Reports based off Salesforce fails in Crystal Reports.
  • After applying a product update, report based off Salesforce.com Command Object fails in Crystal Reports with the error:
        
           Failed to retrieve data from the database.
           Details: HY000:INVALID_FIELD:  <Field Name>
       
           ERROR: at Row:X Column:Y
           No such column: <Column Name> on entity <Name>
           If you are attempting to use custom field, be sure to append the ‘__c’ after the custom field name.
           Please reference your WSDL or the describe call for the appropriate names. [Database Vendor Code: 148 ]’

Environment

  • SAP Crystal Reports 2013
  • SAP Crystal Reports 2016

Reproducing the Issue

  1. In Crystal Reports, create a report off Salesforce.com using a Command Object.
  2. In the Command Objects enter a SQL Query or SOQL Query
  3. Add at least one database field to the report.
  4. When refreshing the report, it fails with the error:
                 
       Failed to retrieve data from the database.
       Details: HY000:INVALID_FIELD:  <Field Name> ...

Cause

  • The issue occurs with the latest update of the SAP Salesforce ODBC Driver version 1.02.07.1019 which is bundled in the following version of Crystal Reports and above:
    • Crystal Reports 2013 - SP09
    • Crystal Reports 2016 - SP04
             
  • The issue has been tracked under SAP Note 2521541

Resolution

  • The issue is currently under investigation by Development.
        
  • To workaround the issue, downgrade your version of Crystal Reports to a version that have a lower version of the SAP Salesforce ODBC driver. The version of Crystal Reports below are using version 1.01.29.1032 of the ODBC Driver where the issue does not exist, and are connecting to Salesforce.com using TLS 1.2
         
    • Crystal Reports 2013
      • Support Pack 06 - Patch 6
             
    • Crystal Reports 2016
      • Support Pack 03

Keywords

CR, SForce , KBA , BI-RA-CR , Crystal Reports designer or BusinessViews Manager , Problem

Product

SAP Crystal Reports all versions