SAP Knowledge Base Article - Public

2519279 - Payment Information: Account Type for country not appearing in UI

Symptom

Country-specific field Account Type, for example  Account Type (USA) is not appearing when adding Payment Information details for USA users in the UI. However, the field appears for the same employee when adding the details through Manage Data.

Environment

Employee Central: Payment Information

Cause

There is a UI rule, which  is responsible for the visibility of this field.

In this rule, you need to reselect the value in the IF condition to activate it.

Resolution

We need to refresh the UI rules, otherwise they don't work. It needs to be done only once.

The below example is for USA, but can be applied to any country and country specific UI rule:

  1. Navigate to Admin Centre -> Manage Configuration UI
  2. Search for the UI that is being used for Payment Information
  3. Hover the mouse over "Payment Information" and click on Manage UI Rules
  4. Click on the rule "USA"
  5. Click on the drop down where "USA" is displayed
  6. Manually search and re-select USA
  7. Click on Save
  8. Repeat the steps 4-7 for other UI rules and refresh all of them
  9. Once all the UI rules are refreshed, click on Close -> Save (in the Manage Configuration UI screen) 

 

Keywords

csf, country-specific, country specific, rule, UI, refresh, account type, missing, payment info , KBA , LOD-SF-EC-PAY , Payment Information (Bank Information) , LOD-SF-EC , Employee Central , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Core all versions