SAP Knowledge Base Article - Public

2513011 - Adding same Item to Questionnaire Survey causes existing Item Survey to become inactive

Symptom

  • Adding same Item to Questionnaire Survey causes existing Item Survey to become inactive
  • Previous responses to the Survey are no longer available under Item Usage in the Survey record

Environment

SAP SucessFactors Learning Management System (LMS)

Reproducing the Issue

  1. Create a simple Item
  2. Create a simple Questionnaire Survey
  3. Associate the Item to the Questionnaire Survey
    • (Learning > Questionnaire Survey > Item Usage > Add an Item to the Survey)
  4. Record learning for several users for the Item in #1
  5. Complete the Survey for those users
  6. Back on the Questionnaire survey, note the Item Usage tab shows Assigned/Completion numbers
  7. Now add the same Item to the Questionnaire Survey
  8. Note no warning pops up, the Item still appears in the Item Usage tab
  9. Assigned/Completions are reset to 0:
    1. Example_ItemUsage.png
    2.    
  10. The original existing Item Survey has been set to Inactive and a new one has replaced it, causing the numbers to reset
    1.  
    2.  

Cause

This has been identified as a defect under LRN-19586

Resolution

This issue has been corrected by release b1711

Workaround:

  • To obtain the missing completion/assignment numbers, run the Item Evaluation Report and mark it to Include Previous Item Associations
  • See KBA 2420037 for more information on the Item Evaluation Report

Keywords

SF SuccessFactors LMS Learning Questionnaire Survey Eval Evaluation reset remove gone missing lose lost loss data previous complete association item usage existing duplicate multiple same add , KBA , LOD-SF-LMS-REP , Reporting Data , LOD-SF-LMS , SuccessFactors Learning , LOD-SF-LMS-PQE , LMS Plateau Question Editor and Evaluation , Bug Filed

Product

SAP SuccessFactors HCM Core 1705