2512691 - Frequently Asked Questions (FAQ) on SuccessFactors Learning Management System (LMS) - Content

SAP Knowledge Base Article - Public

2512691 - Frequently Asked Questions (FAQ) on SuccessFactors Learning Management System (LMS) - Content

Symptom

                                                                                                                                                           SF_LMS_FAQ.png  Content.png
Please also explore our KBAs around more product specific topics

  

Learning.png    Reports.png    Notifications.png    Mobile.png    Connectors.png     Integration.png     Commerce.png     VLS.png



This document is around Frequently Asked Questions on SuccessFactors Learning Management System (Content).

Please note this is a live document. Content will added as we receive more feedback and questions.


Q1: I get "404 File or Directory not found" error when launching content.
A1: We have created a KBA for detailed explanation. Please check our KBA 2403260

Q2: How to update deployment location?
A2: We have created a KBA for detailed explanation. Please check our KBA 2251749

Q3: I am not able to find Deployment Location. What is missing?
A3: This could be happening due to missing workflows. Add the following workflows and it should fix the issue for you:
      - Add Content Deployment Location
      - Delete Content Deployment Location
      - Edit Content Deployment Location
      - View Content Deployment Location
      - Search Content Deployment Location

Q4: I get the error: getzipFile(filename, uploadID, addXMLFilesOnly) error occurred while retrieving the file from DB. How to fix the issue?
A4: We have created a KBA for detailed explanation. Please check our KBA 2316111

Q5: New content is not reflecting in the item. What should I change for the effects to be visible?
A5: Sometimes even after uploading the new content, system reflects old data. This might be the issue with the browser cache memory or with how content is developed.
      We can resolve this as below:
      - It might get resolved on its own: The Akamai server usually takes 1 to 2 days to cache the same content again to keep the content/web pages updated to the latest ones.
        So the issue might get fixed within a day or two on its own.

      - Clear cookies and cache in the browser:
        At times based on the way the content is developed, the contents are cached in the user's browser cache.
        Please request the users to clear the cache and cookies from their browser if they are facing the issues and request them to try again.

      - Clear online content:
         Also, when you are modifying a content at the item level, make sure that you use "Clear Online Content".
         It is under Online Content setting.
         Please do it before you update it with the new content so that the content that is cached(old content) at the server is removed/dissociated properly.

At this point, the item should not be assigned to any user (as there would be a conflict of content). If yes, please remove the item from the users' learning plan.

Q6: Error 403 or logging out abruptly when launching course.
A6: We have created a KBA for detailed explanation. Please check our KBA 2310570

Q7: Content is not sending the completion status.
A7: For example, the content object should send the status as "Passed"(P) or "Completed"(C) which depends on the type of contents.
      Such as AICC or SCORM (http://www.ispringsolutions.com/articles/scorm-structure-and-interaction-with-an-lms.html for more details)
      - If it sends some other improper text as the status, LMS will not recognize it and will not mark it complete
      - If this is the case, all users will have issues with the course.
      - Make sure that the content is configured to send the expected completion status to the LMS for the correct status to be set.

Q8: Settings are incorrect at the Item Level. How to verify the settings?
A8: We have created a KBA for detailed explanation. Please check our KBA 2316953

Q9: The item is showing as locked out, after launching the course from the User's learning Plan.
A9: We have created a KBA for detailed explanation. Please check our KBA 2316902

Q10: Users are not meeting the "completion" requirements. How to fix the issue?
A10: Users are not meeting the "completion" requirements as configured. For example:
        - There are content objects that send the status only when the user clicks a button, such as "Exit" or "Close" or "X" or "Submit" etc., on the last slide/page
        - Some content sends the status when the content/browser window is closed.
        - Some content sends the status the moment it is launched (when the item is set to "Mark this object complete when launched")
        - If this is the case, users who do not complete the courses properly will not receive credit for it.
        - To correct, observe the steps the user is taking to complete the course. Determine which steps may be missed, not meeting the course's requirements for completion.

Please note that receiving completion notifications or certificate doesn't ensure that the completion has been marked.

Q11: What should be the correct session timeout settings.
A11: We have created a KBA for detailed explanation. Please check our KBA 2282975

Q12: How do I implement cross domain solution for SCORM content?
A12: We have created a KBA for detailed explanation. Please check our KBA 2407011.

Note: The server has to be a Web server(Microsoft IIS or Apache, Check out the URL http://whatis.techtarget.com/definition/Web-server for more details on this).

Q13: No Content can be shown as this page has been accessed from an invalid server. What is wrong in my configuration?
A13: We have created a KBA for detailed explanation. Please check our KBA 2290792

Environment

SuccessFactors LMS
Learning Management System

Keywords

Content Completion Status AICC SCORM FAQ , KBA , LOD-SF-LMS-CNT , Content , LOD-SF-LMS , SuccessFactors Learning , How To

Product

SAP SuccessFactors Learning all versions