SAP Knowledge Base Article - Public

2511489 - Troubleshooting performance issues in SAP Analytics Cloud (Collective KBA)

Symptom

Environment

SAP Analytics Cloud (Enterprise)

Cause

There are multiple reasons why performance may be affected. This collective Knowledge Base Article (KBA) describes how to collect more information, how to test your network, browser, stories, data actions and apps (applications written with SAC's application designer) and provides further resources to help overcome performance issues.

Resolution

The overall performance of SAP Analytics Cloud (SAC) is mainly determined by the three components - client time (frontend), network time and the SAP Analytics Cloud service time (backend):

  • The performance of the frontend (client time) is affected by other applications running on your computer. If you have other CPU intensive applications/processes like video conferencing software running in parallel, that will have an impact on other CPU-intensive calculations in SAC like rendering of multiple thousands of cells in a table.
  • The performance on the network is similarly affected by other applications consuming the bandwidth and by some other potential issues over the network caused by VPN, firewalls, bad internet service provider connections, etc.
  • Regarding the backend (SAP Analytics Cloud service time), there is a finite amount of hardware available and multiple concurrent users triggering expensive computations in parallel will slow down processing and have a perceived effect of the overall performance of the system.
  • By using our Performance Analysis tool, you can identify the problematic parts of your scenario and see how much time is spent in which component (frontend, network, backend).
  • To understand the end-to-end time you're perceiving on the client side as well as any instabilities in the overall time or the differences between the different users, you need to check all three pieces and everything affecting them.
    • Note: This tool only traces the performance of stories, data actions and apps (applications written with SAC's application designer).
    • Other activities and navigation actions such as opening the SAC modeler, etc. are not traced.
  • If you have a story, data action or app where the performance is not optimal, run it more than once and check the results in the performance analysis tool to see where the time is spent and compare it for different user sessions, time stamps and systems (production system, test system, QA system, etc.), if needed, taking the above points under consideration.

End_to_End_Response_Time.png

Troubleshooting steps (reproduce, isolate and document)

  1. Review and analyze your scenario using the Performance Analysis tool (This content helps analyze a single story, data action or analytic application).
  2. Follow the steps in the Performance Decision Tree to find resources that will help resolve performance issues.
  3. Reproduce the problem (is the issue reproducible?):
    1. on more than one user’s machine (notebook, mobile device)?
    2. on the same notebook on a different network?
    3. on another story with the same connection?
    4. with a different user login?
    5. with both Google Chrome and Microsoft Edge?
    6. after clearing the browser cache (Ctrl + Shift + Delete  / clear browsing data)?
  4. Isolate the source:
    1. When did the problem start happening? If it worked before, what changed?  If it has always been slow, isolate and simplify the story.
    2. If at all possible, reproduce the issue on a responsive layout story, with a single analytic model using data acquired into SAC.
  5. Document clear reproduction steps when a performance issue occurs.

Browser (client)

  • Ensure that no third-party proxies or other applications are forcing the client (browser) to use the HTTP 1.1 protocol instead of the HTTP 2 protocol see KBA 3056467.
    • Please note: The HTTP/2 Protocol is currently only supported for Live Data Connectivity between SAC and BW and SAP BPC using HTTPS. For more information on how to enable HTTP 2 Support for these data sources, please see HTTP/2 Support.
    • All Network requests made to the SAC, will use HTTP 1.1, as HTTP/2 for these requests is not currently supported.
  • Perform the same action with a different computer. Your computer may be affected by domain policies, browser settings or specific configurations for your user account.
  • Check if other users in your location also experience the same problem.
  • Confirm that correct client software and client configuration requirements at System Requirements and Technical Prerequisites.
  • Enable "High Performance" power plan of your computer's power option plan. See KBA 2327454 - Low performance occurs in tables.

Network

Your network connection has a significant influence on your experience.

Steps to test your network:

  1. Click the System (i) > Performance > Measurement Tool 
  2. Click Run Client Test.
  3. Click Run Network Test.
  4. Take a screen shot of the results.

Measurement Tool.png

  • Wireless: We all love wireless but it is not as fast as Gigabit ethernet and other network adapters.
  • Reverse proxy: Are you using a reverse proxy to access SAP Analytics Cloud? If so, verify that the behavior also happens when you connect to the public SAC URL and access the sample/demonstration stories (Sample - Revenue Analysis).
  • Internet connection: Test network latency from your network to SAP Analytics Cloud. Warning! This is only an estimate. Go to the Network Performance Measurement Tool and test the network bandwidth and latency or use the internet speed test Web site of your choice and simulate a connection to the location where your SAP Analytics Cloud data center is located.
  • VPN: Using VPNs may affect performance as you may be tunneling requests to SAP Analytics Cloud via your VPN connection. You can compare the performance when connected directly to your network. If you notice a significant improvement, contact your VPN / IT administrator.
  • Latency: Latency is measured in milliseconds (ms). It describes the time it takes from the starting request until the response arrives. A good latency is a ping rate within a low milliseconds range. Latency describes the amount of delay on a network or Internet connection. Low latency implies that there are no or almost no delays. High latency implies that there are many delays. One of the main aims of improving performance is to reduce latency.

Stories (Canvas / Responsive / Grid pages)

  • Quick win: Review the sections in the Optimize Your Story's Performance on the SAP Help Portal.
  • Quick win: Best Practice Performance Tips for Story Designers (in design mode) have now been added during story design processes. See the following for more information.
  • Quick win: Enable Optimized View Mode to improve the performance of stories (in certain scenarios) and provides usability improvements. See here, and here.
  • Quick win: Re-save the story to take advantage of incremental improvements since the last update of your system.
  • Quick win: In the model preferences under Data and Performance, toggle on “Optimize Story Building Performance”. This prevents automatic refreshing of data during story design.
  • Simplify story: Use canvas style stories to your advantage. 
  • Chart optimizations: Avoid charts with a large number of data points (>500).
  • Table optimizations: Leverage Explorer instead of using large tables.
  • Images: Resize SVG and PNG files to decrease download times of these files.
  • Linked analytics: Linking too many charts will trigger updating their values every time the selection or filter changes.
  • Settings: Take advantage of Progressive Chart Rendering. See article 2604574 for further information.
  • Blending: Use the "Exclude descendents" option if hierarchies have identical structure & ensure filtering uses currently selected members only (See link dimensions).
  • Geo maps / Geospatial: See KBA 2676310 - Story with geo map loading slowly in SAP Analytics Cloud (SAC) and geospatial best practices.
  • Review the following blog for some further tips and advice: Best Practices for Performance.

Analytics Designer / Analytic Apps

Live Data versus imported data (acquired models)

Data Actions and Planning Features (in Planning models)

Capturing Performance Information in Google Chrome

  • If you have tested all the previous steps and still experience performance problems, please conduct the following so that SAP Product Support can investigate further:
    • Capture a HAR file using the Network tab in Google Chrome Developer Tools. See article 2280022 - How to collect HTTP archive files (HAR) files.
    • Capture a performance trace using the Performance tab in Google Chrome Developer Tools. See article 2413393 for further information.
    • Google Chrome Performance Analysis Reference: Click here
    • Review article 2630653 - How to Troubleshoot and Trace SAP Analytics Cloud connecting to on-premise / acquired / imported data.

SAP Analytics Cloud Performance Analysis Tool and Administration Cockpit

Cloud availability center and data center status

See Also

Your feedback is important to help us improve our knowledge base.

Keywords

slow, performance, speed, C4A, BOC, SAC, AnalyticsCloud, Analytics Cloud, SAP BusinessObjects Cloud, network connection, bandwidth, SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, EPM-ODS, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics, slower, Performance problem, stopped, slow, slowness, hangs, hanging, Cross calculation, sac bp performance sap kba, Performance, system slowness, latency, DC issue, data centre, data center, system slow, system performance, SAC performance issues on planning model, We are encountering Unresposive page pages, Unresposives, waiting issues, unresponsive, processing time, very, very slow, processing time, unproductive, Slowness upload, terrible impact, loading, sac, sac, sap analytics cloud planning, sap analytics cloud training, sap analytics cloud tutorial, user assistance, ua, helpdocs, help information, "sac online help", sap analytics cloud help, sap analytics cloud user guide pdf, sap analytics cloud architecture, sap analytics cloud tutorial, sap analytics cloud connections, sap analytics cloud architecture pdf, learning sap analytics cloud pdf, More accessible documentation on your products and more community resources, SAC Tenant Performance Issues, EPM, SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, Cloud for Planning, EPM-ODS, Cloud for Analytics, C4P, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, HCP, C4A, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJ, BOBJcloud, BOCloud., BICloud, BO Cloud, connecting, conecting, conectando, conexão, modelo, SBOC, SAC, troubleshooting, overview, sap sac, sac, sap analytics cloud planning, sap analytics cloud training, sap analytics cloud tutorial, sac, ua, help, analytics help, support, c4a, boc, analyticscloud, case, troubleshooting, faq, sac faq, sac help, sap analytics cloud documentation, guides, sac support, sap analytics cloud support, ac, SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics,Error, Issue, System, Data, User, Unable, Access, Connection, Sac, Connector, Live, Acquisition, Up, Set, setup, Model, BW, Connect, Story, Tenant, Import, Failed, Using, Working, SAML, SSO, sapanalyticscloud, sap analytical cloud, sap analytical cloud, SAC, ヘルプ, Hilfe zu, Ayuda para, Ajuda para, sap sac, sac, sap analytics cloud planning, sap analytics cloud training, sap analytics cloud tutorial, planning, sac, Analytics Cloud Onpremis install, SAP analytics cloud, SAP BW, stories, geo, story, Analytics designer, sap analyst cloud, https://hcs.cloud.saphttps://hanacloudservices.cloud.saphttps://cloudanalytics.accounts.ondemand.comhttps://hanacloudservices-us.accounts.ondemand.comhttps://www.sap.comhttps://help.sap.com, sap analytics cloud, analytics cloud, cloud analytics, analytics, sac, sap analytics cloud for planning, fp&a, collaborative planning, enterprise planning, extended planning, xP&A, extended planning and analysis, financial planning and analysis, connected planning, integrated planning, workforce planning, headcount planning, allocations, value driver tree, VDT, data action, predictive forecasting, smart predict, planning applications, planning model, advanced formulas, strategic planning, Profit and Loss Planning, P&L planning, bottom-up planning, top-down planning, currency conversion, version management, fp&a, predictive analytics, operational plan(s)(ning), financial planning and analysis, planning tools, integrated business planning, xp&a, integrated planning, collaborative planning, planning model (s), connected planning, enterprise planning, budgeting and forecasting software, enterprise planning, planning and forecasting, planning budgeting and forecasting, planning and analysis, enterprise planning software, financial planning and forecasting, sap analytics cloud planning, predictive planning, driver based models, what if planning, enterprise planning cloud, cloud fp&a, Enterprise Planning, Planning, analysis, budgeting, and prediction in one solution, Embedded business intelligence and predictive analytics, Integration with SAP S/4HANA, Very slow performance when running financial planning stories in SAC. data analysis, data analytics, machine learning, financial planning, business analytics, , KBA , experience poor performance , performance issue with input story , performance for this story has degraded , sac , geo map loading slow story sac kba , sac kba hana live query , sac tenant data issue , sac planning performance slow , sac perf kba perforamnce , oom , sum function does not work in table , sac - performance problems on stories , slowness , sac production bad performance , sac performancnce kba troubleshooting , users experienced extreme slow performan , sap analyst cloud, connected, failure, s , very slow performance of sac planning st , stry story , product functional knowledge , optimize their scenarios , message bad gateway , sac production and test environment , poor performance in , performance issues in new foundry tenant , neo vs cloud foundry , new foundry tenant , performance of sac reports very poor in , very poor in production system , performance is very slow , sac performance issues , very very poor slownesss , sac tenant performance issues , presentation of screens and data , stories are slow to open and navigate co , navigate compare to our norm , super slow performance creating stories , slow response time for /fpa/ , performance issue with , performance issue, slow , performance deteriorates when executing , performance problems - sac , load-and-ad , performance lod-ana-ad , please restart our system to clear syste , system to clear system degradation , very slow performance when running finan , tables keep loading endlessly(showing 3 , sac is very slow , sac performance optimization kba , optimize sac optimized , slowdowns in opening applications or sto , custom formula , custom calculation , for each loops for eachloops , it's taking over minutes to load taking , forever , how to improve performance in the sap an , geo map loadng stowty in story slowly , experience performace , lazy loading laz lazi rendered , experiencing very low performance , and issues in displaying some tables in , fail failed, stopped , geo map loadin slwol story , experience bad performance , for all our users , performance issue and bad gateway error , data loads benchmark , fitlering filtering filters filtered , analyse the lack of performance , impacting month end reporting , "sac tenant performance issues" , and lagging in rendering and presentatio , general slow system wide performance , sluggish performance of general sac nav , general sac navigation , getresponse slow , chart rendering , analytics designer: performance issues, , including slow load loading , bw queries in sac analytics application , "analytic application low performance" , analytic application low performance , analytic application low performance loa , "performance kba sac" , financial planning stories in sac. , endlessly(showing 3 dots in the table) , opening applications or stories , detect dom slowdowns in opening applicat , detect dom slowdown , in opening applications or stories , performnace issue after 2022 q1 upgrade , performnace issue , report execution time increased dratical , drastically story execution time , multi-actions massively degrade system p , degrade system performance. , too much memory required , sac report page doesn't response , pages doesn't respond , performance in one of the report is very , poor low lower , analytics designer - application unrespo , application unresponsive in edit mode , support issues , sac performance analysis tool sap kba , analysis tool sap kba , sac story performance issue , sac kba optimized design mode sac odm , sac performance not as expected sac kba , significant performance issues on sac te , sac test system when multiple users , attempt to plan , sac low performance moments , average runtime , 2511489 , error during the low performance , cloud report/sac excel add in performanc , performance issue - update very slow , sac "run client test" , overcomes processing limits , our cost planning model overcomes proces , sac extreme slowness , cs20230005102678 , sac tenant very slow globally , sac pre-prod and prod systems are very s , pre-prod and prod systems are very slow , sac planning survival , critically low performance , sac production cloud critically low perf , how can i improve my sac story performan , sac story overall performance degradatio , overall performance degradation , LOD-ANA-DES , Story Design & Visualizations , LOD-ANA-PL , Planning , LOD-ANA-BR , SAC Boardroom , LOD-ANA-PR , SAC Predictive , LOD-ANA-ADM , SAC Administration , LOD-ANA-PL-DA , Data Actions , LOD-ANA-AD , Analytics Designer , LOD-ANA-XUS , User assistance, performance statistics , Problem

Product

SAP Analytics Cloud 1.0

Attachments

How to optimize performance for on-premise SAP BW Live connectivity.pdf