SAP Knowledge Base Article - Public

2507493 - Error: 'Assertion failed!' when installing Crystal Reports

Symptom

  • Fail to install Crystal Reports.
  • When installing Crystal Reports, it fails with the error:
           
        "Assertion failed!

         Program: ..ssObjects\InstallData\SetupEngine.exe
         File d:\a42sr32\src\tp.boost\1.60.0\export\.../shared_ptr.hpp
         Line:693

         Expression: px !=0

         For information on how your program can cause an assertion failure, see the Visual C++ documentation on asserts"

Environment

  • SAP Crystal Reports 2016
      
  • SAP Crystal Server 2016
  • SAP Crystal Server 2016 - Client Tools

Reproducing the Issue

  1. Download Crystal Reports.
  2. Run setup.exe as Administrator.
  3. The installation fails with the error:  "Assertion Failed"

Cause

  • Version mismatched between the installed version of Crystal Server 2016, or Crystal Server 2016 client tools, and Crystal Reports 2016.

Resolution

  • Download the Support Pack version of Crystal Reports that matching the Support Pack level of already installed Crystal Server, or Crystal Server Client Tools.
        
    For example:
         
    If you already have Support Pack 02 of Crystal Server 2016 client tools installed on the computer, and are trying to install Support Pack 03 of Crystal Reports 2016, then it will fail to install. The solution are:
         
    • Download and install Support Pack 02 of Crystal Reports, so it match the version of the Crystal Server 2016 Client Tool, of Support Pack 02 that is already installed; or
               
    • Download and install Support Pack 03 of Crystal Server 2016 Client Tools, then you will be able to install Support Pack 03 of Crystal Reports 2016.

Keywords

Assertion failure, CR, CR Server, Crystal Reports Server , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Problem

Product

SAP Crystal Reports 2016