SAP Knowledge Base Article - Public

2507190 - HRIS Sync: Downstream Impacts to Other SuccessFactors HXM Modules

Symptom

  • The Employee Central HRIS Sync feature is used to synchronize data changes between Employee Central and Employee Profile, so that other modules can consume Employee Central related data
  • This KB article explains the possible impact this may have on other modules in the SuccessFactors HXM Suite

Environment

  • SAP SuccessFactors HXM Suite
  • SAP SuccessFactors Employee Central

Cause

When Employee Central is enabled on an instance, the HRIS Sync will ensure that certain data maintained in Employee Central, is also synchronized/replicated to the SAP SuccessFactors HCM Platform (Basic User Data).

BUT - if something fails or stops working, the HRIS Sync is not the first place to check. Usually the cause is that the wrong data is in the Basic User Data file. This could be likely due to the following (in order)-:

  1. Basic User Data was imported, overwriting what HRIS Sync feature had sync'ed there (you can tell via Provisioning > Monitor Jobs > filter on "Import Employee Data" and look for "BasicUserData" imports
  2. HRIS Sync mappings are configured incorrectly - Configuration will always have an impact on Sync logic (depending on how the mappings are configured) which can cause data for some or all users not to synchronize
  3. HRIS Sync job is failing - Provisioning > Monitor Jobs > filter on the second "HRIS Sync" in the list > check for failed jobs

Always check Basic User Data for correctness FIRST, before checking other areas like EC data and HRIS Sync.

Resolution

When working with Employee Central, you must consider that any data changes you are making in Employee Central may impact other modules or even external systems  because of HRIS Sync (depending on your configuration). This is expected behaviour of HRIS Sync and the reason for its being.

This means that when data is changed in Employee Central (where either a hard-coded or custom sync-mapping is defined), the data is synchronized to EP. These changes will result in downstream impacts/changes in other Modules/Systems.

Please do note that for troubleshooting issues in the below listed areas does not require a knowledge of Employee Central sync-mappings. HRIS Sync's end-point is EP. From there, data is consumed by other modules from EP. Therefore the best place to check first is - what value is set in EP. If the value is correct in EP, then likely the issue is with the module/integration consuming that data

Please refer to the table below for a high level overview.

 

Module

 

Area  Impacted Areas Troubleshooting Comments Helpful KBAs & Documents
Platform

Basic User Data

Extended User Information

 

Basic User Data and also EP Extended User Information data (Personal Information only - not Background or Trend)

  • Basic User Data and also EP Extended User Information data (Personal Information only - not Background or Trend) will be overwritten by EC via the HRIS Sync (depending on configuration).

HRIS Sync can synchronize data to standard-elements and userinfo-elements. Therefore the impacts are directly in the Basic User Data (UDF) file and the Extended User Data (EP Personal Information).

SAP SuccessFactors HCM Suite

  • 2080728 - Employee Central: What is HRIS Sync?
  • 2172427 - HRIS Sync - Data Synchronization From EC to EP - Hard Coded Sync Mappings
Role-Based Permissions

Permission Group Population Changes

  • This can result in Target Populations changing
  • This can also result in the Target Group changing, meaning users will get different Permission Roles assigned depending on what Permission Group they become part of
    • This depends on how RBP has been configured (if the Permission Group is using EP fields to define the Membership of the Group).

 

The HRIS Sync job synchronizes data from EC to EP. Therefore if the destination field of the sync (in EP) is a field used by Role-Based Permissions to create Permission Groups, then whenever the relative data in Employee Central is changed, the value will be synchronized to EP (on its Effective Date).

For RBP, this means that the HRIS Sync will impact the Permission Groups used by RBP - this is expected behaviour. For example -:

  1. User A changes Department on 30/10/2017.
  2. On 30/10/2017 the Daily HRIS Sync job runs (as it does every day) and moves the employee to their new Department
  3. The user will move under a new Permission Group. All Permission Groups that are configured to build a group based on the EP field "Department" > the "Membership" will be updated

In the above scenario, this lead to the user being removed from Permission Group A and then included in Permission group B

 

Role-Based Permissions Implementation Guide

  • 2321200 - BizX Platform - Troubleshooting RBP issues : Admin tools & reports
  • 2088818 - Role Based Permissions: Report on permissions assigned to users (RBP) - BizX Platform
  • 2229272 - User role Search - How to check if a User has a Permission (for example Report permission)?
Dynamic Groups

Dynamic Group Population Changes

  • This can result in Target Populations changing
  • This can also result in the Target Group changing, meaning users will get different Permission Roles assigned depending on what Permission Group they become part of
    • This depends on how RBP has been configured (if the Permission Group is using EP fields to define the Membership of the Group).

Dynamic Groups is a feature used by other modules in the SAP SuccessFactors HCM suite. It is not used by Employee Central, but because the HRIS Sync job synchronizes data from EC to EP, HRIS Sync will have an impact on this area.

Dynamic Groups Implementation Guide

  • 2088248 - My Groups: Dynamic Groups
  • 2432747 - My Groups - Dynamic Groups: How to configure if Employee Central is enabled
E-mail Notifications

E-mail Notifications

  • The E-mail Address held in Basic User Data is synchronized with Employee Central > Email Information element
  • E-mail Notifications are used multiple modules in the SAP SuccessFactors HCM suite

 

Depending on whether you are using the hard-coded sync-mappings or custom sync-mappings to set the system "email" for the end user, will determine which Email Type is synchronized to Basic User Data > "email" field.

  • If custom sync-mappings are not defined - the system will synchronize email address based on hard-coded sync-mappings
  • If custom sync-mappings ARE defined - the system will synchronize the email address based on the email-type defined in the custom sync-maping

 

  • 2172427 - HRIS Sync - Data Synchronization From EC to EP - Hard Coded Sync Mappings
  • 2507071 - Employee Central - Email Info HRIS Sync
Work Anniversary tile

The Anniversaries tile on the Home Page will get its data from standard-elements hireDate and dateOfBirth

When EC is enabled, these fields will get their values from EC for EC users (employmentInfo.hireDate and personInfo.date-of-birth).

  • 2579259 - How to configure the Work Anniversary tile to calculate based on Original Start Date
Employee Profile 

Employee Profile

 

Basic User Data and also EP Extended User Information data (Personal Information only - not Background or Trend)

  • The fields in EP will become non-editable (as the source is Employee Central)

 

HRIS Sync can synchronize data to standard-elements and userinfo-elements. Therefore the impacts are directly in the Basic User Data (UDF) file and the Extended User Data (EP Personal Information).

 

  • 2080728 - Employee Central: What is HRIS Sync?
  • 2172427 - HRIS Sync - Data Synchronization From EC to EP - Hard Coded Sync Mappings

Employee Profile

Succession Data Model - standard-element fields

Certain fields are hard-coded to synchronize from EC to EP when Employee Central is enabled. If you enable Employee Central on an instance that previous was using Employee Profile where certain fields which are part of the HRIS Sync hard-coded sync mappings list were maintained as Required on the EP side (the standard-element field), the required status of the field is changed from required="true" to required="false" automatically.

This is because when EC is enabled, the fields are maintained via EC instead (email, gender, department, division, location firstName, lastName, mi, jobCode, managerId) and synchronize to their corresponding Employee Profile standard-element fields

They are made non-mandatory because it would cause HRIS Sync to fail (preventing everything from Job info changes to New Hires from working).

Technically if the standard-element fields were allowed to be maintained as mandatory, and on EC side the field was not mandatory and left blank, the system would attempt to synchronize a "NULL" value to a required field - which would prevent the sync from completing (as you cannot maintain a NULL value in a required field)

This is expected behaviour. It will only happen to fields that are hard-coded to sync.

A list of fields can be found in the article 2172427 - HRIS Sync - Data Synchronization From EC to EP - Hard Coded Sync Mappings.

  • 2172427 - HRIS Sync - Data Synchronization From EC to EP - Hard Coded Sync Mappings
Performance Management  Performance Forms

HRIS Sync governs the data used by Performance Management to determine Manager (and the other system roles), User Info and Competencies. Therefore the impacts are on:

  • Form Creation (the data used when creating the form)
  • Form Routing (changes to roles impacting on form routing)

HRIS Sync will have an impact on Performance Forms, as Basic User Data such as Department, Division, Location, Manager, are all synchronized from Employee Central to Basic User Data.

Therefore, you should always be checking the data in Basic User Data (as this is where Performance Management gets User related data from). If the Basic User Data is correct, possibly there is some issue with the form or some other configuration issue

If data is out of sync between EC and EP, then it is likely that either -:

  • Invalid configuration in the HRIS Sync mappings configuration
  • HRIS Sync job is not scheduled/running/is failing
  • Basic User Data was imported by a user

Performance Management: Implementation Guide

  • 2080650 - How to enable Manager Transfer for Performance Manager forms - Employee Central
  • 2086700 - Employee Change Engine - How to enable when using Employee Central
  • 2342564 - Performance Management: How Employee Central and Intelligent Services affect PM - A Quick Overview
Document Transfer

Document Transfer - (DO NOT USE THIS FEATURE WITH EC ENABLED - see 2509058)

Document Transfer is one tool you should no longer use when Employee Central is enabled. This is because the HRIS Sync feature of Employee Central would normally be configured to manage Form Routing when a users Manager changes. This means that if the Document Transfer feature is used, you are again over-riding Employee Central, which could lead to data inconsistencies/validity issues

 

  • 2509058 - HRIS Sync: Why not to use Performance Management Document Transfer when Employee Central is enabled
Competencies (Families and Roles)

Competencies (mapped with Job Classification - determines which Competencies the user will have on their form)

 

When Employee Central is enabled, manually entered "jobCode" data is no longer entered into the system. Instead, the "Job Classification" from Employee Central is synchronized to the jobCode field in EP (in the format of "Name (Code").

If the correct Competencies are not linked in the Performance Form when it gets create, this will indicate a few different Configuration / Data Issues -:

  • Check the "jobCode" column in the Basic User Data (Admin Center > Employee Export) and ensure that the "Job Classification" is correctly set in "jobCode" for the user
  • job-code > jobCode custom sync-mapping is defined in the Succession Data Model and even after Full Sync, the correct Job Classification is not set - (this mapping should be removed - see KBA 2172427)
  • The customer has not yet updated their existing Families and Roles to link with Job Classifications (see the KBA - 2080013)
  • The HRIS Sync job did not run or failed

 

  • 2080013 - How to Manage Families & Roles and Competency Mappings - Employee Central
  • 2172427 - HRIS Sync - Data Synchronization From EC to EP - Hard Coded Sync Mappings
Compensation & Variable Pay

Compensation Forms

Variable Pay Forms

Employee Profile data is consumed by Compensation/Variable Pay Forms such as-:

  • Basic User Data such as First Name, Last Name, Date of Birth, etc.
  • Compensation related fields
  • Role Information (Manager, Matrix Manager, Second Manager, etc)

 

When Employee Central is enabled, information such as Name, Manager, HR Manager (and other roles) are managed in Employee Central, and then synchronized to Basic User Data (UDF) for consumption.

The HRIS Sync should be taken into careful consideration when planning a Compensation / Variable Pay configuration in an instance with Employee Central enabled.

You can automatically trigger the following Compensation/Variable Pay related actions the HRIS Sync job is triggered (in Full Sync or Daily Sync mode).

  • Update Compensation Forms
  • Update Variable Pay Forms

If either of these are enabled, then the "open" forms will be updated after the HRIS Sync job is completed.

In an instance where Employee Central is not enabled, you would normally trigger the above 2 processes via the "Employee Import" feature, but when Employee Central is enabled, you are best to consider enabling these options on the job to ensure forms are updated when data changes in EC.

The flow of data works as such -:  EC Data is changed/approved > HRIS Sync will synchronize the data to Basic User Data > Forms will then be updated based on the updated Basic User Data.

If you find that the EC and EP data are out of sync, you can consider running a Full HRIS Sync job as it will re-synchronize all EC data mapped to EP.

It is still possible to use the "Basic User Import" to override/byass the HRIS Sync job - meaning that you can still trigger the form updates via Basic User Import. Please note however, that performing the data update via Basic User Data import is effectively overwriting data that was synchronized from EC. Therefore, the next time a Full HRIS Sync job is run, or an employees EC data is updated, it will (via HRIS sync) synchronize to Basic User Data and overwrite the data you imported.

It is Best Practice to always use HRIS Sync to ensure Forms are updated when data is synchronized from EC. But as noted, you can always bypass this if needed and import the data via Admin Center > Import Employee Data > Basic User Import. It is also note supported to disable HRIS Sync when EC is enabled.

 

Compensation Management

Variable Pay

Helpful KBAs:

  • 2509201 - HRIS Sync: How does the HRIS Sync impact Compensation Management
  • 2339802 - Hybrid templates: EC and non-EC users - Compensation Management
  • 2429831 - Compensation - Reasons why fields in Job Information and Compensation Information are updating the User Directory File
  • 2080065 - What is a Full HRIS Sync? - Employee Central

Compensation Forms

Variable Pay Forms

Hierarchy Changes

Approvals Tab

 

If the hierarchy is changed (employees moved to different managers) and the HRIS sync does not run, then the Compensation Approvals tab will not display the expected hierarchy changes

If the Second Manager hierarchy is not being updated (or any Role related information) when Job relationships data in Employee Central is updated, then it is likely that either -:

  1. HRIS Sync job is failing or failed during the point in time where the users data was updated
  2. The Job Relationships feature in Employee Central is not configured correctly (see 2079986)
  3. Basic User Data file was imported where role changes were made (overriding the data that was synchronized from EC)

For more information on Job relationship sync, please refer to the following KBA's

  • 2079986 - HRIS Sync - How does HRIS Sync map EC Job Relationships to system roles
Compensation Statements

 Compensation Statement

 

Some field data in the Compensation Statement comes straight from Compensation Info (for certain fields) in Employee Central. When generating Compensation/Variable Pay statements, some of the standard fields are picked not from the Compensation Forms but directly from the Basic User Data (which is where HRIS Sync will synchronize data to).

Ensure you are checking the Basic User Data file (Admin Center > Employee Export) to verify the data is correct there, and not the Compensation Form.

As this portlet is Pre-Delivered, it is not configurable - therefore if incorrect data is displayed in the portlet/statement - it means the incorrect data is stored in either Compensation Info in Employee Central, or Basic User Data (Admin Center > Employee Export) and should be corrected.

 

  • 2085136 - Statements - Personal Compensation Statements - Compensation
  • 2085141 - Statements - Generating Compensation Statements - Compensation
Learning Management LMS Connector

 

  • The LMS Connector job will Import data into the LMS system. The LMS Connector file is basically a "Basic User Data" Export csv file (EP data - UDF), used by LMS to integrate BizX and LMS users.
  • Changes to Employee Central data will be synchronized to Basic User Data - which is then consumed by LMS via the LMS Connector job

If the data is correct in Basic User Data file (Admin Center > Employee Export) then the issue is not with HRIS Sync.

Make sure the data from the Employee Export file created in provisioning matches (or it’s accurate) comparing with one from the “Admin Center > Employee Export”, considering the reports can have different info based on the filters/permissions. Please see the documentation mentioned in the next column.


Importing User Data from Platform with User Connector - SF

  • 2318341 - LMS Connectors Knowledge Support and Tips

 Analytics

 

Advanced Reporting (ODS/Realms)

 Data is out of Sync between EC and Advanced Reporting

There is no connection between the HRIS Sync feature and the Advanced Reporting tool. If the data between Employee Central and Advanced Reporting are out of sync, this indicates there is an issue with Advanced Reporting, and has no relation to the HRIS Sync feature.

 

Employee Central Advanced Reporting Implementation Guide

  • 2276691 - Advanced Reporting Data is Out of Synch with Employee Central Data
  • 2279026 - Employee Central Advanced Reporting Implementation Tips & Tricks from Support

 

Legacy Reports

Dashboards

 

Basic User Data fields used to filter reports/dashboards such as department, division, location, custom01, etc (depending on HRIS Sync configuration).

The impacts here are that, with Employee Central enabled, fields such as Department, Division, Location are all managed by Employee Central via the HRIS Sync. These values are no longer manually entered via Admin Center > Employee Import, but are instead synchronized via the HRIS Sync feature, from EC to EP.

 

 Succession

Company Org Chart

The Company Org Chart does not reflect the hierarchy defined in Employee Central

 

If the Company Org Chart (Basic Org Chart) does not reflect the current hierarchy/reporting line defined in Employee Central, then it is likely that data is not synchronized from Employee Central to Basic User Data.

This does not nessecarily indicate that the HRIS Sync is the root cause though. Ideally always check the validity of the data in the Basic User Data (UDF) file (Admin Center > Employee Export) to verify that the hierarchy/data is correct there. If it is correct in the Basic User Data (UDF) then the issue is much less likely to be with HRIS Sync, and more likely with the "LnR" hierarchy table used to build the Team View and Org Chart hierarchy

 

Succession Management: Implementation and Administration Guide

  • 2080175 - How often does the Basic Organization Chart get updated? - Employee Central
  • 2227861 - Direct Report Employee is not displayed in Org Chart after selecting "One Level Up" from the Org Chart UI

See Also

2080728 - Employee Central: What is HRIS Sync?
2080730 - Employee Central: HRIS Sync - Troubleshooting Guide
2172427 - HRIS Sync - Data Synchronization From EC to EP - Hard Coded Sync Mappings

Keywords

sf, success factors, hris-mapping, hris-sync-mappings, hris sync, succession data model, xml, sdm, employee central, ec, sync , KBA , LOD-SF-EC-HRS , HRIS Sync , LOD-SF-EC , Employee Central , LOD-SF-LMS , Learning Management System , LOD-SF-PLT , Platform Foundational Capabilities , LOD-SF-ANA , Analytics & Reporting (Ad Hoc, YouCalc, ORD) , LOD-SF-EP , People Profile (Employee Profile / PP3) , LOD-SF-SCM , Succession Management , LOD-SF-PM , Performance Management , LOD-SF-CMP , Compensation Management , LOD-SF-VRP , Variable Pay Programs , How To

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM all versions