SAP Knowledge Base Article - Public

2499952 - Tomcat can't deploy correctly C4A_AGENT - unable to load class com.sap.fpa.cloud.rest.cs.DriverManager

Symptom

You downloaded the latest SAP Analytics Cloud Agent following the product's guide. After starting Tomcat, the deployment fails and the logs shows:

SEVERE: Error configuring application listener of class com.sap.fpa.cloud.rest.cs.DriverManager
java.lang.UnsupportedClassVersionError: com/sap/fpa/cloud/rest/cs/DriverManager : Unsupported major.minor version 51.0 (unable to load class com.sap.fpa.cloud.rest.cs.DriverManager)

Environment

  • SAP Analytics Cloud 2017
  • Tomcat 7.x from SAP BusinessObjects Business Intelligence installation

Cause

The SAP JAVA JRE version is old and needs to be updated.

Resolution

  1. Download and install SAP JVM version 8 from https://tools.hana.ondemand.com/#cloud
  2. Stop Tomcat
  3. Change Tomcat's Java Settings > Java Virtual machine and point to the new path where you installed the SAP JVM, for example: C:\SAP\sapjvm_8\jre\bin\server\jvm.dll
  4. Start Tomcat

Change_JRE_JVM.png

See Also

Your feedback is important to help us improve our knowledge base.
Please rate how useful you found this article by using the star rating feature at the beginning of this article.
Thank you.

Keywords

EPM, SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, Hana Cloud for Planning, EPM-ODS, Cloud for Analytics, C4P, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, HCP, C4A, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJ, BOBJcloud, BOCloud., BICloud, BO Cloud, connecting, conecting, conectando, conexão, modelo, SBOC, SAC , KBA , LOD-ANA , SAP Analytics Cloud , LOD-ANA-BI , SAP Analytics Cloud - Business Intelligence (BOC) , LOD-ANA-PL , SAP Analytics Cloud – Planning (BOC) , LOD-ANA-BR , SAP Analytics Cloud - Digital Boardroom , LOD-ANA-PR , SAP Analytics Cloud – Predictive (BOC) , Problem

Product

SAP Analytics Cloud 1.0