2489437 - Issue while adding a user to an existing slot throws error.

SAP Knowledge Base Article - Public

2489437 - Issue while adding a user to an existing slot throws error.

Symptom

When enrolling a user to a slot from the admin side in a scheduled offering, that is having a price associated, the below error is thrown.

Error : Chargeback Account provided for User (UserID) cannot be used with Slot ID

Environment

LMS - Learning Management System

SuccessFactors LMS

Reproducing the Issue

Try enrolling a user to an open slot that is having price associated. You will see the error screen mentioned below.

Chargeback.png

NOTE : Make sure that the user, scheduled offering are having the account codes & charge back settings associated properly.

For more details regarding chargeback settings kindly refer the KBA 2416242

Cause

The settings here mention that the slot added to the Schedule Offering has price associated to it which in turn is associated to the organization.

Now this means that a slot is kept aside with a price for a given organization,meaning that the users who are enrolled in the Slot dont have to pay amount again.

Once Slot is created with a price then the system assumes that the price is paid by the organization and hence users dont have to again pay.

Resolution

Please remove the price while registering the user from the admin side as shown in the below screen and add the user, which would resolve the issue.

ChargebackSettings.JPG

Keywords

Registering to slots Chargeback account SlotID Chargeback Account provided for User cannot be used with Slot ID , KBA , LOD-SF-LMS-COM , Commerce , Problem

Product

SAP SuccessFactors Learning all versions