2486509 - Learning Mobile App - Catalog Search empty

SAP Knowledge Base Article - Public

2486509 - Learning Mobile App - Catalog Search empty

Symptom

When searching the Catalog in the SuccessFactors app, it is empty and displays not items.

It Displays the message 'No Search Results Found' as in below image.

Mobile screenshot Catalog.png

Environment

SuccessFactors Learning Management System (LMS) - from b1702

Cause

This issue can be caused by the search language in the catalog not matching the language of the catalog items.

As there is no option to select the language in the mobile app, the mobile catalog search uses the same language that the user has set in the desktop version of the catalog.

Resolution

The search language that is set in the users desktop catalog will also be set as the language in the app

  1. Navigate to the catalog in the desktop version of LMS
  2. Select 'Language & Currency'
  3. Set the Primary language and secondary language if required
  4. Select OK

Calalog Language.png

These language settings will now also be applied in the catalog search in the mobile app and Items in the selected language should now be visible in the catalog in the mobile app.

Keywords

Mobile; App; Catalog, Catalogue, Language, Learning Mobile App, Catalog Search, Language & Currency , KBA , LOD-SF-LMS-MOB , Learning Mobile Application , How To

Product

SAP SuccessFactors Learning all versions