2485701 - API User Insufficient field-level permission

SAP Knowledge Base Article - Public

2485701 - API User Insufficient field-level permission

Symptom

  • The API user used for making user profile updates via API was temporarily de-activated
  • It was activated again and was granted all the accesses
  • But still the API calls fails with error "insufficient field-level permission"

 <content type="application/xml">
            <m:properties>
                <d:key>User/userId=******</d:key>
                <d:status>ERROR</d:status>
                <d:editStatus m:null="true"></d:editStatus>
                <d:message>Insufficient field-level permission</d:message>
                <d:index m:type="Edm.Int32">0</d:index>
                <d:httpCode m:type="Edm.Int32">403</d:httpCode>
                <d:inlineResults m:type="Bag(SFOData.UpsertResult)"></d:inlineResults>
            </m:properties>
        </content>

Environment

  • BizX Platform

Reproducing the Issue

  • What happens is, when this API user is inactive and then set active again (roles untouched), the API call  that uses this user, errors with the  following
  • <d:message>Insufficient field-level permission</d:message>

Cause

  • When admin lacks field level permission and employee import permission, the admin will not be able to update user's any field.
  • When admin lacks employee import permission but have fields permission, the admin will be able to modify user's related field but not password.
  • When admin has employee import permission, the admin will be able to modify user's password no matter the admin have field permission or not.

Resolution

Grant the employee import to the Dev API user:

 

  1. Access the Manage Emploee Import

 API_USER_KBA.png

  1. Grant the permission to import. Tick “ALL” boxes for each option available.

 API_USER_KBA2.png

Keywords

Insufficient field-level permission, Re-activate API User , KBA , LOD-SF-PLT , Foundational Capabilities & Tools , LOD-SF-INT , SF Integrations - EC Payroll, Boomi/ HCI, API , Problem

Product

SAP SuccessFactors HCM Suite all versions