2476874 - Product Category Replicated From ERP to C4C Has '#' Appended

SAP Knowledge Base Article - Public

2476874 - Product Category Replicated From ERP to C4C Has '#' Appended

Symptom

New product categories replicated from ERP to C4C are getting created with # in the beginning.

Reproducing the Issue

  • Product Category replicated to C4C with # as the first character followed by the category ID
  • Idoc contains the category ID without # and C4C Incoming Message contains the category ID(ReceiverInternalID) with # 

Cause

  • The # appended before the Product Category is due to the standard mapping that is provided by SAP.
  • Please check the screenshot(Mapping1) attached. This logic is defined because most of the customers will create Product Categories with leading zero's .
  • However in C4C , we don't consider leading zeros while we show the data on UI or save the data in backend.
  • To make sure that leading zeros are not removed , we pass # which will get appended as first character.

Resolution

  • If you will never create leading zeros for product category in ERP, you can adjust the mapping as per the screenshot attached(Mapping2).
  • As highlighted in the screenshot, you can remove the logic to concatinate # with ID 
  • Instead you can map ID(from IDoc structure) to ReceiverInternalID(C4C structure) and this will fix this issue.

Keywords

KBA , LOD-CRM-EMP , Employee , How To

Product

SAP HYBRIS C4C ADDINS 1705 ; SAP Hybris Cloud for Customer 1702 ; SAP Hybris Cloud for Customer 1708 ; SAP Hybris Cloud for Customer 1711

Attachments

Mapping1.JPG
Mapping2.JPG