2470892 - ORD filter for LMS is not showing all values

SAP Knowledge Base Article - Public

2470892 - ORD filter for LMS is not showing all values

Symptom

  • Create a LMS report in ORD, go to Manage Filters or Runtime filter, select a filter, click on report value, try to search for some values and see that it is not showing results
  • Report values in LMS filter in ORD hit a limit while clicking in Next button

Environment

SuccessFactors Workforce Analytics (ANA) - All versions

Reproducing the Issue

  1. Create a ORD report of LMS domain
  2. Go to Manage Filters or Runtime filters
  3. Select a Filter field
  4. Click on Report Values
  5. Try to search for a specific value
  6. See that there is no result
  7. Clear the Search
  8. Click Next button 20 times
  9. See that it hits a limit and does not show anymore values
    filter2.png

Cause

There is a 200 list value limit in filters for LMS in ORD. This is a limitation from LMS domain itself.

Resolution

If you have more than 200 records being returned in the list you need to directly enter the exact value to create the report, rather than selecting them from a list.

  1. Click on Enter filter value:
  2. Put the exact value to filter
  3. Click Select
  4. See Seleced Values right panel
  5. Click OK

filter3.png

Keywords

LMS report in ORD Learning Manage Filters Runtime record missing all value search result show not limit filter , KBA , LOD-SF-ANA , Analytics & Reporting (Ad Hoc, ORD) , LOD-SF-LMS-REP , Reporting Data , Product Enhancement

Product

SAP SuccessFactors Workforce Analytics all versions