2469948 - LMS: "Browse all courses" not showing the items even though user is part of catalog.

SAP Knowledge Base Article - Public

2469948 - LMS: "Browse all courses" not showing the items even though user is part of catalog.

Symptom

User is unable to search for the items that are part of a catalog to which he/she is having access to and is getting the below screen when searched for anything.

catalogsearch.JPG

Environment

SuccessFactors LMS

Learning Management System

Reproducing the Issue

  1. Log in to LMS as user.
  2. Search for the item from the catalog.

Cause

  • The item title is not created for the language(s) used by the user during catalog search.

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Resolution

The fix for this there are two options:

  1. User needs to correct the language used when searching by:
    • Manually chaging the primary or secondary language as shown in the previous screenshot.
    • Updating the default language via 'Options and Settings' (under 'Links' in the Home Page)
  2. Admin to update the item title for that language
    • Admin > Learning > ***Edit the item*** > ***Hover the mouse to the item title and click the 'Locale' icon*** > ***Update the value of the locale being used by the user(s) then save***

2016-11-18_10-52-32(2).png

See Also

2186608 - Cannot find the item when searches for the same in the catalog even if the item is in the catalog and catalog is assigned to the user if seen from the admin side| screen showing message: No result match your search match -Learning Management system

2073597 - SITE: Catalog availability to external users

Keywords

Browse all courses Browse Catalog Search There are no search results with your keyword or search criteria. Please remove your criteria and try a new search Find Learning Catalog search page , KBA , LOD-SF-LMS-COR , LMS Core - Items, Catalog, Curricula , LOD-SF-LMS , SuccessFactors Learning , LOD-SF-LMS-CAT , LMS Catalog , Problem

Product

SAP SuccessFactors Learning all versions