2468577 - Campaign ID Not Available in Task Activities Migration Template

SAP Knowledge Base Article - Public

2468577 - Campaign ID Not Available in Task Activities Migration Template

Symptom

When attempting to migrate Task Activities into the system, the Campaign ID field is not available in the Migration template.

Reproducing the Issue

  1. Go to Business Configuration work center
  2. Select Overview view
  3. Search for migration of task activities
  4. Under Configuration Element, you can find the Migration of Task Activities activity
  5. Click on the hyperlink to open the activity
  6. Click on Migrate task activities using the migration tool to open the Workbench
  7. Click on You Can Also and select Download Migration Template
  8. Open the file which is downloaded to see Campaign ID field not available in the template.

Cause

This is an expected system behavior.

Resolution

The best alternative is to use the Task Follow Up and Related Items node of the Tasks object in the Data Workbench work center.

  1. Head to the Data Workbench work center;
  2. Go to the Import tab;
  3. Under the Task object, select Task Follow Up and Related Items node;
  4. Click the Download metadata link to the right to download the template;
  5. In the template, populate the following fields as instructed:
    1. BusinessTransactionDocumentRelationshipRoleCode (value should be 1)
    2. ID (value should be the internal ID for the Campaign)
    3. TypeCode (value should be 764)
    4. TaskID (value should be the internal ID for the Task you want to associate with the previously mentioned Campaign)
  6. Save template;
  7. Back in the Import tab, with Task Follow Up and Related Items selected, click Next;
  8. In the next screen, under Select Data File, click Browse to locate the template;
  9. Click Next and proceed with the import.

Keywords

KBA , AP-RC-BCT , Business Config. Tools (SAP Business ByDesign , How To

Product

SAP HYBRIS C4C 1705 ; SAP Hybris Cloud for Customer 1611 ; SAP Hybris Cloud for Customer 1702 ; SAP Hybris Cloud for Customer 1708