SAP Knowledge Base Article - Public

2467444 - Survey Simulation Does Not Work

Symptom

When you simulate a survey, a blank page opens up and the simulation does not work.

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

  1. Go to the Surveys work center.
  2. Go to the Surveys view.
  3. Open the survey ABC (ABC represents the survey ID).
  4. Choose the Simulation button.

A blank page is opened and the survey is not simulated.

Cause

The survey was not designed correctly.

Resolution

Following points need to be noted while creating surveys:

  1. Do not set the page break indicator in a Question with question of Type: Section.
  2. Do not set the page break indicator in a Question where Branching is set. This means that if any Branch To field is filled or Default Branching is filled.
  3. Do not set the Branching in a question of Type: Matrix. For example, initially the Question Type was changed to Multiple Choice, then you set the Branch To and then again changed the Question Type back to Matrix. This will cause inconsistency.
  4. Do not set the page break Indicator in the Last Question, because by default it will break it and send to next page for completion of survey.
  5. Note that the matrix view is only possible without branching. Page breaks cannot be used.

See Also

SAP Help Portal: SAP Hybris Cloud for Customer Administrator Guide: Surveys

Keywords

Survey, page break indicator , KBA , LOD-LE-SUR-DEF , Survey definition = design time , How To

Product

SAP Cloud for Customer all versions