2462547 - Viewing a Lumira report results in the error "An error occurred in the data manipulation engine. Check the manipulation parameters. (HDB 01001)"

SAP Knowledge Base Article - Public

2462547 - Viewing a Lumira report results in the error "An error occurred in the data manipulation engine. Check the manipulation parameters. (HDB 01001)"

Symptom

  • Viewing a Lumira report via the BI Launchpad results in the following error:
    "An error occurred in the data manipulation engine. Check the manipulation parameters. (HDB 01001)"
  • Logs show the following:
    Caused by: java.lang.UnsatisfiedLinkError: <E:\BOB\SAP BusinessObjects Enterprise XI 4.0\java\pjs\container\work\<SERVER_NAME>.LumiraServer\org.eclipse.osgi\bundles\138\1\.cp\hl-lib\vcruntime140.dll>: Can't find dependent libraries

Environment

  • SAP Lumira server for the BI Platform 1.31.4
  • Windows Server 2012
  • SAP BusinessObjects Business Intelligence (BI)  4.2 SP03 Patch 4

Reproducing the Issue

  1. Open the BI Launchpad
  2. View any Lumira report

Cause

  • Microsoft Visual C++ 2015 has not been installed correctly

Resolution

  1. Check under Windows Control Panel > "Programs and Features" that MS Visual C++ 2015 redistributable (x64) version 14.0.24210 is installed on the system where Lumira Server 1.31.4 is deployed.
  2. If not, please go to the Microsoft website here https://www.microsoft.com/en-gb/download/details.aspx?id=48145

Keywords

Lumira Lumira Server C++ , KBA , BI-LUM-SRV-DEP , Lumira Server BI Platform installation, deployment , Problem

Product

SAP Lumira, desktop edition 1.0