2461051 - Lumira assertion failed during installation of server LS4BIP 2.0

SAP Knowledge Base Article - Public

2461051 - Lumira assertion failed during installation of server LS4BIP 2.0

Symptom

When installing LS4BIP 2.0, following errors are encountered:

Assertion failed!

Program: ..ssObjects\InstallData\setup.engine\SetupEngine.exe
File: <drive>:\a42sr32\src\tp.boost\export\iface\b.../shared_prt.hpp
Line: 315

Expression: px != 0

For information on how your program can cause an assertion failure, see the Visual C++ documentation on asserts

bip-error.JPG 

Environment

  • SAP BusinessObjects Lumira Server for BI Platform 2.0 (EAC build)
  • SAP BusinessObjects Business Intelligence Platform 4.2 SP4 (beta)

Reproducing the Issue

  1. Download and install Lumira Server for BI Platform 2.0

Cause

Current EAC release of LS4BIP 2 incompatible with 4.2 SP4

It is not supported per PAM: https://support.sap.com/content/dam/library/ssp/infopages/pam-essentials/TIP/SAP%20Lumira/SAP%20Lumira%202.0/SAPLUMIRA_PAM.pdf

Resolution

Compatibility with BI 4.2 SP4 will be introduced in future releases (Currently planned 2.0 SP02)

Currently, it is recommended to test Lumira 2.0 Server on a supported platform as per PAM.

For more information, see the following SAP Note:
2467541 - Supported BI Platform Add-On versions information for the SAP BusinessObjects BI 4.2 SP04 release

Keywords

KBA , BI-LUM-SRV-DEP , Lumira Server BI Platform installation, deployment , Problem

Product

SAP Lumira, desktop edition 1.0