2459740 - Report Distributor Runtime failure - Encountered a problem while processing E-mail

SAP Knowledge Base Article - Public

2459740 - Report Distributor Runtime failure - Encountered a problem while processing E-mail

Symptom

  • Bundles in Report Distributor are failing
  • Job Status displays Runtime failure - Encountered a problem while processing E-mail

Environment

SuccessFactors Workforce Analytics (ANA) - All versions

Reproducing the Issue

  1. Go to Analytics
  2. Report Distributor
  3. Select a bundle
  4. On the left panel Menu click on Run Report Distributor
  5. Open Job Status
  6. See that bundle status is 'Runtime failure' - Encountered a problem while processing E-mail
  7. Also this same error happens to scheduled bundles

runtime failure.png

The bundle will stop running if it encounters a problem in one recipient. Therefore, the next recipients will not receive the email.

  • If the bundle fails for the first recipient, all the other users will not receive the file.
  • If the bundle fails for the second recipient, the first user will receive the file, but the others will not.

Cause

We have more than one cause for this issue. Here we will see three scenarios that result this error.

  • Some recipients of the bundle were manually created in WFA/Analytics, thereby they do not have a company ID matching with BizX and the system cannot confirm the user's permission to receive the report.

wfa users.png

 

  • The second possibility is that the reports inside the bundle have validation errors.

validation.png

 

  • Third scenario is regarding permission if the report is built from Live Data in Detailed Reporting. A recipient may not have access to run Ad hoc reports for the specific sub domain schema.

Resolution

  • First scenario: To fix the first issue you need to delete these users with blank Company ID from WFA and let Analytics automatically create them. Please follow the steps below:
  1. Go to Analytics > Admin > User Maintenance
  2. Choose Columns
  3. Add Internal id and SF Company
  4. Note if they are blank for some users
  5. If they are, then
  6. Delete the user with blank Company ID
  7. In another browser, proxy and then go to WFA/Analytics as that user
  8. This will create the user in WFA User Maintenance properly
  9. Try the bundle again
  • Second scenario: For the second issue you need to
  1. Go to Analytics > Admin > Instace Validation
  2. Validate the affected report(s)
  3. Check the validation errors and fix the reports
  • Third scenario: You need to provide RBP permission to see the data of the report.
  1. Go to Analytics > Report Distributor
  2. Select the bundle
  3. Click on the name of the report to edit the query
  4. In query designer click on Edit on the left panel side. Check what sub domain schemas the report is built
  5. Go to Admin center > Set User Permissions > View user permission
  6. Confirm that the recipient from the bundle has Reports Permission to run the Adhoc sub domain schemas available in the report

Please see also the Reference KBAs for more information.

 

 

Keywords

Scheduled, bundle, failed , KBA , LOD-SF-WFA , Workforce Analytics & Planning , LOD-SF-WFA-WA , Workforce Anaytics , Problem

Product

SAP SuccessFactors Workforce Analytics all versions