SAP Knowledge Base Article - Public

2457826 - Email mapping that is defined for Offboarding are not working

Symptom

  • Allthough business and personal email mapping for offboarding has been setup correctly between Onboarding and EC, you may notice that only EC Primary email is returned.

Environment

  • SAP Successfactors HCM Suite
  • Employee Central
  • Onboarding

Reproducing the Issue

  1. Create mapping between offboarding and EC field for personal or business email.
  2. Try hiring employee
  3. Note how it will show primary email no matter what.

Cause

  • Engineering defined this currently as as limitation in offboarding mapping API.
  • There is currently no code to accomodate the various email mapping between EC and Offboarding.

Resolution

  • An Enhancement request on this was created and Engineering are working on adding this.
  • Milestone has ben set to 1708. (Do note that this milestone may change).

Keywords

ECT-70000, offboarding, employee Central, mapping email , KBA , LOD-SF-EC-INT , Suite Integration (EC to RCM, ONB, CVP) , Product Enhancement

Product

SAP SuccessFactors HCM Core 1702