2456094 - CTI Does Not Work in HTML5 With IE Anymore

SAP Knowledge Base Article - Public

2456094 - CTI Does Not Work in HTML5 With IE Anymore

Symptom

CTI does not work in HTML5 with IE anymore, but it does work in SL and other browsers.

Reproducing the Issue

Scenario I.

  1. Open SAP Hybris Cloud for Customer as HTML5 client in IE.
  2. Click on the Live Activity pane.
  3. Open the CTI Adapter.
  4. Click on the Simulate button.
  5. Click the Simulate button again in the new opened window.
  6. No inbound call is visible in the Live Activity pane.

 

Scenario II.

  1. Open SAP Hybris Cloud for Customer as HTML5 client in IE.
  2. Go to the Service work centre.
  3. Select the Tickets view.
  4. Open a Ticket.
  5. Click on the phone number hyperlink of an account.
  6. No outbound call is executed.

Cause

The Embedded CTI Integration pane is enabled.

Resolution

In order to be able to perform inbound and outbound calls again you have to disable the Embedded CTI Integration pane.

In order to do so you have to use the following steps:

  1. Log into the Silverlight client.
  2. Click on the Live Activity pane.
  3. Select the Actions button and choose the Personalize option.
  4. Select the Adapt button and choose the Enter Adapt Mode option.
  5. Select the Adapt button and choose the Edit Screen option.
  6. Remove the flag for Embedded CTI Integration.
  7. Save and publish the changes.

You should be able to perform inbound and outbound calls again.

Keywords

KBA , SRD-CC , Cross Components , How To

Product

SAP HYBRIS C4C ADDINS 1705 ; SAP Hybris Cloud for Customer 1702 ; SAP Hybris Cloud for Customer 1708 ; SAP LE APPL.PLATFORM 1702 ; SAP LE APPL.PLATFORM 1705