2443636 - Eligibility rules are being applied over more than 24 hours

SAP Knowledge Base Article - Public

2443636 - Eligibility rules are being applied over more than 24 hours

Symptom

When applying the Eligibility rule for a template, it will take more than an hour for the rule to be applied and the page will be stuck in loading/applying rule page.

Environment

Compensation

Reproducing the Issue

Compensation > Select Template > Plan Setup > Plan Details > Eligibility > Notice that it will take more than an hour to apply the rule

Eligibility.PNG

Cause

Root cause: Sometimes the rules is applied and there could be a deployment, so the flag in the database is already updated with the rule running and it goes out of sync, so we need to manually clear the database flag.

Resolution

  • Go to the Provisioning
  • Navigate to Clear Eligibility rule flag
  • Select the template
  • Clear eligibilty flag
  • Re-apply the Eligibility rule in the instance

Eligibility2.PNG

Keywords

Eligibility rule , KBA , LOD-SF-CMP-GDL , Guidelines, setup, data, etc. , Problem

Product

SAP SuccessFactors HCM Suite all versions