2442453 - Notification not triggering when offboarding via ATS/XML

SAP Knowledge Base Article - Public

2442453 - Notification not triggering when offboarding via ATS/XML

Symptom

I'm offboarding an employee using XML via ATS , I'm expecting a notification to be triggered as soon as the offboarding activity is created.  

Environment

Onboarding All DC

Reproducing the Issue

Offboarding Notification is configured
candidate is offboarded via ATS (XML)
activity created in Workqueue however Notification is not triggered

Cause

Trigger point of the notification is not met. 

Resolution

1. Check/edit the Notification
2. Check "Notify At" and see the step when Notification is configured to be triggered. for eg : On Intiation step
off1.JPG

3. Check the XML used for Offboarding
4. look for Process passed and step defined for eg :
<!-- Process to Start  -->
 <xpresshr:Fieldname="XpressHR.Process" value="OFF" />
<!--
First Process Step 
 -->
<xpresshr:Fieldname="XpressHR.StartStep" value="2" />

5. In above eg. Process passed is OFF where as Step passed is which means Employee step and not the Initiation step thus ignoring step 1 and directly starting with step 2
So, Notification will not get triggered as step 1 never executed.

Keywords

Offboarding ATS XML
Notification not triggered offboarding
notification not triggered XML ATS , KBA , LOD-SF-OBD-OFF , Offboarding , Problem

Product

SAP SuccessFactors HCM Core 1611 ; SAP SuccessFactors Onboarding 1511 ; SAP SuccessFactors Onboarding 1602 ; SAP SuccessFactors Onboarding 1605 ; SAP SuccessFactors Onboarding 1608 ; SAP SuccessFactors Onboarding 1611 ; SAP SuccessFactors Onboarding 1702 ; SAP SuccessFactors Onboarding 1705 ; SuccessFactors Onboarding 1305 ; SuccessFactors Onboarding 1308 ; SuccessFactors Onboarding 1311 ; SuccessFactors Onboarding 1402 ; SuccessFactors Onboarding 1405 ; SuccessFactors Onboarding 1408 ; SuccessFactors Onboarding 1411 ; SuccessFactors Onboarding 1502 ; SuccessFactors Onboarding 1505 ; SuccessFactors Onboarding 1508