SAP Knowledge Base Article - Public

2437516 - "No Data" is Shown When Clicking on Browse All Courses in Catalog 3.0 - LMS

Symptom

  • After upgrading to Catalog 3.0, clicking on Browse All Courses from the Find learning tile, results in No Data.
  • Items are not showing in Catalog 3.0 Search.

2437516 symptom.png

 Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Learning Management System

Reproducing the Issue

  1. Login as user
  2. Navigate to Learning home page
  3. Click on Browse All Courses
  4. No Data is displayed

Cause

There are two possible causes of the No Data in the Browse All Courses search:

  • There is an incorrect system configuration of Catalog related settings.
  • Items are not marked as "Featured","New" or "Revised" in the catalog for which the users have access to.

Resolution

To show all the Items in the catalog:

  1. Go to System Admin > Configuration > System Configuration > edit Catalog

resolution1.png

  1. Look for catalogBrowseEnabled= and set it to false (catalogBrowseEnabled=false)
  2. Apply changes

Or to enable the flag items feature:

  1. Login as Admin > Go to Learning > Catalog (search for the affected catalog)
  2. Select the Items tab. There is an option to set the Flag as Featured, New & Revised.
  3. Select a flag from the drop down > Save

2437516  resolution 1.png

See Also

KB article - 2752876 - Hidden Refine Search in Catalog 3.0 - LMS

Keywords

SF, Success Factors, LMS, learning, No Data, Catalog 3.0, Browse All Courses, catalogBrowseEnabled, flag, Featured, New, Revised, configuration , KBA , LOD-SF-LMS-COR , LMS Core - Items, Catalog, Curricula , Problem

Product

SAP SuccessFactors Learning all versions