SAP Knowledge Base Article - Public

2436570 - Basic search by extension fields does not return any results

Symptom

You try to search, via the basic search for a value which is contained in an extension field but the result is not as expected.

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

As example we are using the Tickets view, the same issue can happen in other areas of the system.

  1. Go to the Service Workcenter.
  2. Go to the Tickets View.
  3. Select All from the dropdown list.
  4. Search for FieldXYZ (FieldXYZ represents the example of the extension field).

Notice that no results are shown.

Cause

The system behaviour for the basic search consists in having a search limited to a fixed number of set fields, so if an extension field is added to the system, such field will not be searchable using the basic search unless the field is added to the advanced search screen via adaption mode.

Resolution

In order to make the extension fields searchable via the basic search, the extension field must be added to the advanced search as well via the edit screen in adaption mode.

  1. Go to the Service workcenter.
  2. Go to the Tickets View.
  3. Select Adapt -> Edit Masterlayout.
  4. Select the advanced filter to expand the list of searchable fields.
  5. Select Adapt and Edit Screen.
  6. Select Extension Fields then Advanced Filter.
  7. You should now see the extension field ABC, which you can make visible by ticking the visible box.
  8. Save and publish, if you are happy and want to have this setting available for all users.

The extension field FieldXYZ is now visible on the advanced search pane and can be searched for, using the basic search.

See Also

2634654 - Basic Search For PDI Field Values

Keywords

Extension field, KUT field, search, Advanced filter, Basic search , KBA , searchable , basic search , LOD-CRM-EMP , Employee , How To

Product

SAP Cloud for Customer all versions ; SAP HYBRIS C4C CORE all versions