2432535 - Can updates in candidate profile update current application?

SAP Knowledge Base Article - Public

2432535 - Can updates in candidate profile update current application?

Symptom

  • When candidate updates personal information (phone, email, etc) in their candidate profile, said information is not updated in application.

Environment

  • SAP SuccessFactors
  • Recruitment Management (RCM)

Reproducing the Issue

  1. Candidate applies to job
  2. Advance application in pipeline
  3. Candidate updates profile
  4. Changes are not synched in application

Cause

  • Data syncs from the Candidate Profile to the Application only at the point where the candidate initially applies to a job
  • Subsequent updates to the Candidate Profile will not update the Application
  • Data syncs from the Application back to the Candidate Profile at any time if it is changed on the Application
  • The system assumes the most recent updates should always be fed back to the Candidate Profile

Resolution

Possible solutions:

  • Enable Multistage application, add a status in the pipeline (for example, candidate pre-boarding update) and then permission candidate to edit contact information fields, such as address, phone number etc:
    • To enable Multistage application, you will need to contact a partner to provide analysis, recommendations and start implementation project for said the feature.
    • Multistage application is a rather complex change in your process.
  • Enable "Edit Candidate Profile Snapshot - Recruiting" KBA 2081634. This will allow permission operator to update candidate fields.

See Also

Keywords

SF SuccessFactors Success Factors Recruit Manage RCM modify change edit app candidate profile update candidate profile synch application synch   , KBA , LOD-SF-RCM-APP , Applicants and Job Applications , Problem

Product

SAP SuccessFactors Recruiting 1608