SAP Knowledge Base Article - Public

2427719 - Advanced / ORD report does not return value on BizX/ ORD language change

Symptom

  • Advanced / ORD Report does not display data when BizX/ ORD language is changed.
  • Report appears as blank due to incorrect filter settings when language is changed. 
  • Labels of filter values are changed of Advanced / ORD report when language is switched from one Language to other (English US to English UK).

Environment

  • Advanced Reporting
  • Realms
  • Online Report Designer

Reproducing the Issue

  1. Create Advanced Report in English US language.
  2. Below filter is placed in the report:
    • "Employee Status in "Non Paid Leave of Absence", "Paid Leave of Absence"

English USA.png

          3. Share the report with a user whose BizX and ORD language is set as English UK.
          4. Report doesn't return any value for this user. 
          5. Go to Filter Designer > Edit the filter 
          6. Employee Status field does not have value - "Paid Leave of Absence", "Paid Leave of Absence" in drop down list.
          7. When language is set to English UK, label of filter values changed to "Paid Leave", "Unpaid Leave"

      English UK.png

     

Resolution

  • Change the BizX and Analytics language to English USA and run the report OR
  • Set the ID of the filed instead of selecting values in Filter OR
  • Set the runtime filter instead of setting static filter OR
  • Edit the report and select the appropriate values while laguage is changed to English UK.

Keywords

  • Advanced Report
  • ORD
  • English US to English UK
  • Filter Label change
  • Analytics Language
  • ORD language
  • Report Blank
, KBA , LOD-SF-ANA-ODS , Advanced Reporting , LOD-SF-ANA-ORD , Online Report Designer , Problem

Product

SAP SuccessFactors HCM Core all versions