SAP Knowledge Base Article - Public

2427247 - iContent files updated by FTP not updated in LMS

Symptom

Files hosted by iContent appear to take a long time to be updated if a new version is loaded to the iContent server via FTP.

Is this due to the Akamai caching? How often are new versions checked for?

Environment

SuccessFactors Learning Management System (LMS) - from version 1611 onwards

Reproducing the Issue

  1. Upload a new version of a content file with the same filename to the existing path on the SFTP server.
  2. Users still see the old version of the content in LMS.

Cause

Once applied, Akamai will cache your static content so any course updates posted via ftp may take up to 24 hours to take effect.

Resolution

You can ensure updates take immediate effect by uploading updates to a new folder and updating the launch URL in the LMS.

Keywords

iContent, update, updating, akamai, content, FTP, Akamai caching, , KBA , LOD-SF-LMS-CNT , Content , LOD-SF-LMS-PCM , LMS Icontent , Problem

Product

SAP SuccessFactors Learning all versions