SAP Knowledge Base Article - Public

2426338 - Upcoming Class Reminder Email Notification not getting triggered for the users

Symptom

User hasn't received the email notification to remind them of an upcoming class.

Environment

SAP SuccessFactors Learning

Cause

For the following scenario:
If number of days left for the for Class Start Date is less than threshold set at Upcoming Class Reminder Email Notification automatic process level and Reminder emails have already been triggered for the users who were enrolled before.

Then the new user registered is not getting the reminder email when the APM runs next.

Resolution

Once "Upcoming Class Reminder Email Notification" APM sends reminder notification for a Class, then it will not send any reminders again for the same Class. So if any new users register for the Class after the reminder is sent, then they will not get the reminder emails.

The reason for which is as the reminder email notifications are already triggered for the Class, then the database updates the RMNDR_SENT column as "Y" for PA_SCHED table, when the APM see if the RMNDR_SENT is 'Y' it will not trigger emails for it.

  • It is possible to run "Class Data" report to check the "Reminder Sent" column of the report and verify if the reminder has been already triggered for that class.

See Also

 SAP Help Portal: Template ID to Trigger to Receiver Map (login may be required)

Keywords

Threshold, class, delivery notification, reminder, future class, e-mail, ApmInstanceDelivery , KBA , LOD-SF-LMS-NOT , Notifications , LOD-SF-LMS-SCH , Class - Scheduled Offerings , Product Enhancement

Product

SAP SuccessFactors Learning all versions