2414704 - Record Learning error: 403 forbidden , Error requesting access token

SAP Knowledge Base Article - Public

2414704 - Record Learning error: 403 forbidden , Error requesting access token

Symptom

Some admins are unable to record learning for item(s) or schedule Offerings

  • com.plateausystems.elms.util.helper.ElmsUncheckedException: org.springframework.security.oauth2.consumer.OAuth2AccessDeniedException: Error requesting access token.
    	at com.plateau.sfintegration.impl.trainingevent.CDPTrainingEventServiceImpl.addComponentTrainingEvent(CDPTrainingEventServiceImpl.java:224)
  • Caused by: org.springframework.security.oauth2.consumer.OAuth2AccessDeniedException: Error requesting access token.
  • Caused by: org.springframework.web.client.HttpClientErrorException: 403 Forbidden

Environment

  • Learning Management system (LMS)
  • Learning admin interface accessed from Bizx (or integrated)
  • Record learning wizard
  • Career Development Plan

Reproducing the Issue

  1. login to CDP (also known as Career Development Plan module) and add a Learning Activity for a user or as a user (self-assigned)
  2. LMS Admin: go to the LMS Admin side (in integrated mode- via Bizx) and try recording the learning for the user via the Record Learning Tool
    OR
    Try recording the learning from the Actions menu of the Schedule Offering record 
  3. the error will be displayed and the learning will not be recorded

Cause

  • The communication failure between the LMs and the CDP module is due to a difference in the users/Admin IDs mapping. This prevents the Admin from recording the learning completion.
  • LMS and CDP being two different modules there is a validation process required to authorize communication (in this case: updating the completion status in CDP for the learning recorded in LMS) between both modules.
  • One of the criteria required for this validation to be successful is to have matching match IDs for Bizx user, LMS user and LMS Admin who is performing the recording activity.

Resolution

The ID mapping needs to be corrected to ensure that BizX user ID= LMS User ID = LMS Admin ID.

In most cases Bizx ID=LMS User ID but the LMS admin ID is different and therefore a new admin account needs to be created and related to the LMS user:

  1. LMS Admin> System Admin> Application Admin> Admin Management > search for the admin record who is facing the issue
  2. remove the association with the current user in LMS (delete the value in the field: "related user" in the Summary Tab)
  3. create a new Admin record with an ID that matches the LMS user ID and Bizx ID
  4. in this new Admin record: associate the corresponding LMS user ID in the "related user" field in the Summary Tab

Matching the IDs is the best recommended practice in a SuccessFactors integrated environment.

See Also

An enhancement will be released in 1705 version of the LMS (ref: LRN-16663) that will allow these IDs to differ.

Keywords

Career; Development; Plan; activity; record, completed; complete; record learning financial; record learning multiple; completion;OAuth2AccessDeniedException: Error requesting access token;HttpClientErrorException: 403 Forbidden , KBA , LOD-SF-LMS-CDP , LMS Career Development Program , LOD-SF-LMS , SuccessFactors Learning , LOD-SF-LMS-ADM , Admin Tools , LOD-SF-LMS-INT , LMS Integrations , Problem

Product

SAP SuccessFactors Learning 1602