SAP Knowledge Base Article - Public

2413999 - Survey Link Not Working in Campaign E-mails

Symptom

When you execute an e-mail campaign with a survey link, the e-mail received will have the survey link as inactive.

Reproducing the Issue

  1. Go to the Marketing workcenter.
  2. Go to the Campaigns view.
  3. Open the campaign ABC.
  4. In the Build tab, Email with Survey link has been added.
  5. Choose Actions and then Send Test e-mail.
  6. You are able to open the survey link from the received e-mail.
  7. Now, execute the campaign.
  8. The recipients from the target group have received the email but the survey link is inactive.

 

Cause

The link to external surveys used in the email templates for campaigns works only for the members of the type: Person. Because it is expected that when a link to external survey is sent in an email it would be clicked by a Person. In this case, if we send an email to contact or the individual customer it would work fine. But if the email is sent to an account, the link doesn't work.

Resolution

  1. Go to the Marketing workcenter.
  2. Go to the Campaigns view.
  3. Open the campaign ABC.
  4. In the Overview tab, choose the Target group.
  5. Navigate to the Members tab.

Here, ensure that the members are not accounts.

 

Keywords

KBA , LOD-CRM-EMP , Employee , How To

Product

SAP HYBRIS C4C ADDINS 1705 ; SAP Hybris Cloud for Customer 1611 ; SAP Hybris Cloud for Customer 1702 ; SAP LE APPL.PLATFORM 1611 ; SAP LE APPL.PLATFORM 1702 ; SAP LE APPL.PLATFORM 1705