2408209 - No results returned when adding a field from another domain in ORD Detailed Reporting Live Data (Cross Domain Reporting)

SAP Knowledge Base Article - Public

2408209 - No results returned when adding a field from another domain in ORD Detailed Reporting Live Data (Cross Domain Reporting)

Symptom

I am trying to create a cross domain report in ORD Detailed Reporting using Live Data.  However whenever I add a new field from another subdomain schema, the query returns no results.

For example: Add fields from the Recruting V2 domain, then add one field from the Employee Profile domain -->  report went blank and did not return results.

Environment

  • SuccessFactors Reporting and Analytics
  • Online Report Designer

Cause

Incorrect fields used to define the join or relationship scope.

Resolution

  1. Check the Relationship Scope of the query by going to Edit > Relationship Scope.
  2. See that the field selected for schema 1 will correctly match data for the field selected in schema 2. 

    For example, depending on the report you are trying to pull, choose the User Sys ID field from Candidate for Recruiting V2 domain, while for the Employee Profile choose User Sys ID from Employee.  Here you are using a field common to both schemas, User Sys ID, and you are sure that the values are the same so matching records will be retrieved.

Another example is when the join is between Development Objective and Employee Profile, ensure that the definition is "Development Objective User Sys ID = Employee Profile User Sys ID" and  NOT Development Objective ID = Employee Profile User Sys ID

relationship scope.jpg

Keywords

Cross Domain, Relationship Scope, ORD, Detailed Reporting, Live Data, table join , KBA , LOD-SF-ANA , Analytics & Reporting (Ad Hoc, ORD) , How To

Product

SAP SuccessFactors HCM Core 1611