Symptom
- Error: "0 while trying to invoke the method java.io.File.isDirectory() of a null object loaded from local variable 'directory'"
- Error: "Unable to check if documentExists: Server Error"
- Preference panel cannot open by clicking menu File > Preferences
- Extensions panel cannot open by clicking menu File -> Extensions
- Process hangs at the "Acquisition completed" stage option when try to create a new Lumira document
- Below trace log observed in trace file
====================
+1100|Information|Information|==|S| |TraceLog| 8008| 42|Thread-16 | ||||||||||||||||||||com.sap.hilo.desktop.v2.V2Main$StreamGobbler||SAPLumira.exe output: [xxxx/xx:ERROR:ssl_client_socket_openssl.cc(1071)] handshake failed; returned 0, SSL error code 1, net_error -117
====================
Environment
- SAP Lumira Desktop 1.0
Cause
Errors like java.io.File.isDirectory() and documentExists: Server Error are typical java errors. So should be related Java / JVM setting.
Resolution
- Check if multiple java versions installed in OS.
- Classpath / JAVA_HOME / PATH setting in system variables. Check if they are not pointing to the jre path.
If there is no CLASSPATH set in system variable, add CLASSPATH = %JAVA_HOME%\bin - Or point Lumira Desktop to use your Java Virtual Machine
- Edit C:\Program Files\SAP Lumira\Desktop\SAPLumira.ini in notepad or other text editor.
- At the very top of the file add these lines (note they should be two separate lines):
- -vm
C:\Program Files\Java\jre1.8.0_31\bin - The path most likely will be different depending on the install and version of Java you have.
- Save the file and start Lumira.
See Also
- 2124755 - Unable to Launch Lumira Desktop due to Java Access Bridge Issue
Keywords
java , jvm , jre , java.io.File.isDirectory , isDirectory , isDirectory() , documentExists , KBA , BI-LUM-DIS , Lumira Desktop/Discovery , How To
Product
SAP Lumira, desktop edition 1.0