2401470 - LMS Custom Reports returning blank after upgrading to 1611

SAP Knowledge Base Article - Public

2401470 - LMS Custom Reports returning blank after upgrading to 1611

Symptom

  • After upgrading to release b1611, Custom Reports are no longer returning data
  • Prior to upgrading, these reports returned data

Environment

  • SAP SuccessFactors
  • Learning Management System (LMS)

Reproducing the Issue

  1. Login to an instance that has been upgraded
  2. Run a custom report
  3. Note that it returns blank, all data is missing

Cause

  • This may be caused by special characters in the SQL comments

Resolution

  1. Open the report in Plateau Report Designer
  2. Check the comments in the SQL
  3. Replace any special characters in the comment section, such as single apostrophes (')
  4. Examples of a comments that begins with double dashes (--) and contains an apostrophe:
    • --Calculer le nombre d'apprenants
    • --Return User's Name
  5. Once these are remove or replaced, save and upload the report
  6. Test again, and the report should now return data
  7. If the issue persists, check the KBAs listed below in the "See Also" section

Please note that we can only provide a limited amount of support for customization

Additional assistance may be found in the SuccessFactors Community or through Consulting services

See Also

KBA 2368497LMS BIRT CSV reports return no data after b1608 release

KBA 2381411 - LMS Custom reports missing data

KBA 2320765 - LMS Reports Knowledge Support and Tips

Keywords

SF SuccessFactors LMS Learning Management System custom BIRT report blank missing empty no data upgrade PRD , KBA , LOD-SF-LMS-REP , Reporting Data , Problem

Product

SAP SuccessFactors HCM Core 1608