SAP Knowledge Base Article - Public

2400802 - Career Site Builder Custom Fonts not working in Internet Explorer - Recruiting Marketing

Symptom

When using Career Site Builder Custom Fonts functionality, it is possible that Internet Explorer will not properly render this custom font, although it will work as expected on other internet browsers (such as Google Chrome and Mozilla Firefox).

Environment

SuccessFactors Recruiting Marketing (RMK) - Career Site Builder (CSB) versions

Reproducing the Issue

The issue can be easily recreated by pulling up the site in Internet Explorer and the same page in another browser. Placed side by side, you can see the font difference. The issue can be replicated only on Internet Explorer 9+ versions.

Cause

This issue is caused by an Internet Explorer limitation. The web browser is currently unable to work with all existing fonts.

Resolution

In order to ensure that a font will work on Internet Explorer, it should be checked (before uploading in CSB) for the file property ‘Font embeddability’.

The below image shows how to view the file property.

1.png

 

Steps are:

 

  1. Right click on the font file
  2. Click on ‘properties’
  3. Click on ‘details’ tab.
  4. The ‘Font embeddability’ should be ‘Installable’.

 

Values for this property that will not work in Internet Explorer include ‘Preview & Print’ ‘No Embedding’ and ‘Editable’.
This requirement for True Type Fonts in Internet Explorer is described in Microsoft documentation https://blogs.msdn.microsoft.com/ie/2010/07/15/the-css-corner-better-web-typography-for-better-design/ and https://msdn.microsoft.com/en-us/library/ms533034.aspx.

Keywords

Career Site Builder, CSB, Custom fonts not working, Error: “CSS3114: @font-face failed OpenType embedding permission check.  , KBA , LOD-SF-RMK , Recruiting Marketing , Problem

Product

SAP SuccessFactors Recruiting all versions