2383257 - LMS: Catalog search for items with underscores doesn't return results

SAP Knowledge Base Article - Public

2383257 - LMS: Catalog search for items with underscores doesn't return results

Symptom

Learning items that are configured with underscores in the ID or description do not return results when user searches catalog for a word which is in the ID.

Environment

SAP SuccessFactors Learning - all supported versions

Reproducing the Issue

  1. Create a learning item with an underscore (e.g. KL_Test Item)
  2. Add the item to a catalog.
  3. Access Learning User interface, click browse catalog.
  4. Search _Test or Test Item - no results are returned.

Cause

Catalog search engine is not configured to search for items in this format.

Resolution

Change the catalogSearchEngine property from DEFAULT to OCCURRENCE_RELEVANCE or PROGRESSIVE_RELEVANCE.

In versions prior to b1608, follow the steps below.  If versions b1608 and higher, you can access all catalog related settings in Admin > System Admin > Configuration > Catalog.

  1. Access LMS Admin > Admin > System Admin > Configuration > System Configuration.
  2. Click to edit the LMS_ADMIN configuration properties.
  3. Using (Ctrl+F), search for the term catalogSearchEngine.
  4. Set it to catalogSearchEngine=OCCURRENCE_RELEVANCE or catalogSearchEngine=PROGRESSIVE_RELEVANCE. 
  5. Apply changes.

 

Keywords

browse, not found, _, quotes, quotations, punctuation, "", wildcard, **, lms, learning management, user search, catalogsearchengine, search engine, kal, kac , KBA , LOD-SF-LMS , SuccessFactors Learning , Problem

Product

SAP SuccessFactors Learning all versions