SAP Knowledge Base Article - Public

2380944 - Note Field On Header VS Notes Facet

Symptom

The Notes field on the Customer header does not update to the last Note entered in the Notes facet.

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

Prerequisite: You have enabled both the Notes field on the Customer header, as well as the Notes facet.

  1. Go to the Customer work centre.
  2. Go to the Accounts view.
  3. Open any Customer ABC (ABC represents the customer's name).
  4. For the Notes field on the header, enter any free text X11 (X11 represents the free text entered)
  5. Go to the Notes facet and enter any note X22.
  6. Enter a second note X33 within the Notes facet.

Result: The Notes field on the Customer header does not update to display X33.

Cause

The Notes field in the header displays whatever (free) text is entered within that field; however, it corresponds to only the first Note entered within the Notes facet.

Resolution

We advise not to show the free Text field in the Header, when the Notes facet is being used.
If the aim is to be able to create some free Text for Accounts, use the field in the header. However, if the requirement is to create several (ongoing) notes, the Notes facet should be used.

Keywords

note, notes facet, header, notes , KBA , account , notes , header , notes facet , SRD-CC , Cross Components , How To

Product

SAP Cloud for Customer all versions