SAP Knowledge Base Article - Public

2371918 - Custom Member filter is not working or it is not available for some users

Symptom

  • A custom member based on a structural dimension (e.g. Organizational Unit), set as publicly shared, still does not appear in the Special Functions section of Report By or Limit By in the Filters panel.
  • A report with a custom member as filter is not showing the same result for all users

Environment

SAP SuccessFactors Workforce Analytics

Cause

If a Custom Member allows access to any categories in the dimension which are restricted by a user or role's Tree Security, it will not be selectable as a filter as it will not display its full range of categories, which might lead to confusion.  This is true even if the purpose of the custom member is to exclude a single category; if Tree Security restricts any of the others, it will register as invalid and not appear.

Resolution

Custom members restricted for this reason are still available for use in Query Workspace.  If they are required as filters, however, Tree Security must be relaxed so that all included categories are available for a given user or role.

Keywords

Custom Member filter is not working or it is not available for some users WFA inconsistent result , KBA , LOD-SF-WFA , Workforce Analytics & Planning , Problem

Product

SAP SuccessFactors Workforce Analytics 1605