SAP Knowledge Base Article - Public

2371329 - Data is Missing in the System After Creating the Patch Solution

Symptom

You observe that after enabling the newly created patch, the data that you have maintained in the original solution, are not visible in the UI.

Reproducing the Issue

  1. Login to the UI.
  2. Navigate to the respective screen.
  3. The values you have maintained for the custom fields are missing.

Cause

The reason for this is, any data created for the original solution in the SAP cloud solution and any scoping decisions and fine-tuning settings are not copied to the patch solution. Hence the data from the original solution will not be visible. If you enable the original solution instead of the patch solution, then the values will be visible again. This is the standard behavior as these are two different namespaces.

Resolution

For testing purposes, you must therefore scope the patch solution and create new test data in your test tenants.

Note: This will happen only when you create the first patch, if you create any data on this patch, the subsequent patch creations will not lose the data that you have created.

 

See Also

You can also refer to the SAP Cloud Application Studio help document with the below path:

SAP Cloud Application Studio -> Administration and Life Cycle Management -> Developing on a customers tenant -> Create a Patch on a Test Tenant

Keywords

KBA , AP-RC-BCT , Business Config. Tools (SAP Business ByDesign , How To

Product

SAP BUSINESS BYDESIGN 1705 ; SAP BUSINESS BYDESIGN 1708 ; SAP Business ByDesign 1702 ; SAP Business ByDesign 1711 ; SAP HYBRIS C4C ADDINS 1705 ; SAP Hybris Cloud for Customer 1702 ; SAP Hybris Cloud for Customer 1708 ; SAP Hybris Cloud for Customer 1711