SAP Knowledge Base Article - Public

2368893 - Unable to See Item in the LMS Catalog Search

Symptom

  • Item is not found in the LMS catalog search
  • After creating a new item, all users are unable to see the item in the catalog it is assigned to when searching for it
  • No results match search returns when searching for the new item. Please try to undo last selection, clear all selection, expand your search by removing filters

Environment

SAP SuccessFactors Learning Management System

Cause

  1. The item's "show in catalog" value is set to NO. This will prevent it from being seen in any search functionality on the user’s side.
  2. The user that's being used to search in the catalog does not have access to that particular Catalog where the item was published.

Resolution

  1. Go to Learning > Search for Item > View All > Set the item's "Show in Catalog" value to YES:

2368893 reso1.png

  1. To confirm if the user has access to that particular Catalog - Users > Search for user ID > Related (More) > Catalog Preview:

2368893 reso2.png

  1. If the user does not have access, please use an Assignment Profile in order to grant the permission to the user. Refer to KBA 2677659 - How to assign catalogs to users - LMS

Keywords

SF, Success Factors, LMS, learning, see items, Unable, cannot search course, catalog, user, assignment, preview , KBA , LOD-SF-LMS-CAT , Catalog , LOD-SF-LMS-COR , LMS Core - Items, Catalog, Curricula , Problem

Product

SAP SuccessFactors Learning all versions