SAP Knowledge Base Article - Public

2364032 - Report shows Failed status in Learning Management System (LMS)

Symptom

  • When running a report in the Learning Management System (LMS), the status returned as "Failed"
  • The following message is displayed:
    • The system was unable to generate your report due to an error. You can try again, or contact your system administrator for more information and assistance.

Environment

  • SAP SuccessFactors Enterprise Learning
  • Learning Management System (LMS)

Reproducing the Issue

  1. Login as a user
  2. Navigate to the Links tile and select Reports
  3. Run any report
  4. Status returns as Failed and displays the message:
    1. "The system was unable to generate your report due to an error. You can try again, or contact your system administrator for more information and assistance."

Cause

  • This is due to the User not having a Locale set
  • Reports require the I18nLocaleVO variable to have a value set for the user's locale

Resolution

Set the User's Locale

Logged in as the User:

  1. Login as the user
  2. Navigate to "Options and Settings" in the "Links" tile
  3. Under "Select a Locale and Time Zone", set your preferred locale
  4. Click "Apply Changes"

 

As the Administrator:

  1. Login as an Administrator
  2. Navigate to "Users" and search for the user with the issue
  3. Open the User's record
  4. In the "Related" menu (bottom left), click the "More" link
  5. Select the "Preferences" tab on the left
  6. Set the user's locale and other required fields (marked with red star)
    1. lcoale.png
  7. Save the user record
  8. Test reports as that user again

Keywords

SF SuccessFactors Success Factors LMS Learning Management System report fail failed failing external user never returns doesn't won't show display error specific all every locale local language I18nLocaleVO null variable , KBA , LOD-SF-LMS , SuccessFactors Learning , Problem

Product

SAP SuccessFactors Learning 1602