SAP Knowledge Base Article - Public

2362679 - Error While Creating Job Requisition via Org Chart "INSERTED with the index 0" - Recruiting Management / Employee Central

Symptom

While creating a Job Requisition from Position Org Chart, the user encountered with an error - "INSERTED with the index 0".

    2019-03-22_10-35-59.png

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP SuccessFactors Recruiting Management - All Versions
  • SAP SuccessFactors Employee Central - All Versions

Reproducing the Issue

  1. Go to Org Chart -> Position Org Chart tab
  2. Select the position that you want to create a requisition
  3. Open the position -> Show Menu -> Create Job Requisition
  4. An error message will show up

    2019-03-22_10-38-39.png

Cause

There is a lack of settings that are required to create Job Requisition via Position Org Chart and the following causes belong to Recruiting Management configurations. Below are the main configuration issues that could be causing the error message:

1. Missing RBP permissions:

There is a few permissions that need to be granted to the user in order to have the ability to see the Job Requisitions template and create the requisitions. The user who is creating the requisitions doesn't have permissions role access to the following:

General User Permission

  • Permission to Create Forms (Select the Forms you want to grant permission)

Manage Form Templates

  • Form Templates
  • Mass create form instances(Launch forms now)
  • Schedule Mass Form Creating(Launch forms later)

2. Missing User Login permission for the user/s that are in the Route Map:

Users configured in the Route Map configuration have the login permission missing, that means the system will not allow the user to create the requisition, if the users that will approve have no access to the system. Following permission is required for the mentioned users:

General User Permission

  • User Login

3. Business Rule doesn't have a user or the user doesn't exist anymore:

There is one or more rules configured in the Job Requisition field mapping rule, which have a specific userSysId for a recruiting role, where this user doesn't exist or it was deleted. Example of mapping:

  RecruitingRoleUser.jpg

4. Inside the Route Map settings, one or more stage/step doesn't have a role associated:

When you are building a Route Map that will be related to a form, you need to define which role belong to which stage of the Route Map and in case you have one or more missing role, the system you throw the error. E.g., Create Requisition step you need to define the role as Originator.

Resolution

In order to have the mentioned configuration issues resolved, please follow the below steps:

1. Missing RBP permissions:

  • Permission to Create Forms (Select the Forms you want to grant permission)
  • Form Templates
  • Mass create form instances(Launch forms now)
  • Schedule Mass Form Creating(Launch forms later)
  1. In Admin Center -> Manage Permissions Role
  2. Select the role
    1. Under User Permissions -> Scroll to General User Permission
    2. Check 'Permission to Create Forms'
    3. Under Administrator Permissions -> Go to Manage Form Templates
    4. Check 
      • Form Templates
      • Mass create form instances(Launch forms now)
      • Schedule Mass Form Creating(Launch forms later)
  3. Save the changes

Note: If the user doesn't have '

2. Grant access to user/users from Route Map approval process

  1. Check all the users who are there selected in the Job Requisition Route Map
  2. Make sure that all the approvers have below permissions under RBP
    1. User Permissions -> General User Permission
    2. Check 'User Login'
  3. Save all the changes

3. Inactive User been part of the Route Map approval process

Validate all the field mapping rules that have an User ID to a role/operator as a value and check if the exact User ID does exist in the system or if has been inactived.

  1. Admin Center -> Configure Business Rules
  2. Open the rules which have an User Id as value
  3. Check if these respective user are active in the system
  4. Save the changes 

NOTE: Instance sync is used t copy configuration settings, including rules, from one instance to another and with that, it may be possible the system created the rule without a validated User Sys Id. 

4. Inside the Route Map settings, one or more stage/step doesn't have a role associated:

For the specific Job Requisition template you is getting the error message, check the Route Map form associate it and check if all the stages have a role selected. 

  1. Admin Center -> Manage Route Map
  2. Open the Route Map that is associate to the Job Requistion template
  3. Check if all the stages have a role selected
  4. Save the changes

   2019-03-25_9-49-34.png

See Also

2088055 - Instance Synchronization Feature Guide & need to know information - Platform

Keywords

Position, RequisitionViaPositionOrgChart, INSERTED, Index, Requisition, INSERTED with the index 0 , KBA , LOD-SF-RCM , Recruiting Management , LOD-SF-EC , Employee Central , LOD-SF-EC-POS , Position Management , LOD-SF-RCM-INT , Integration Center & Intelligent Services , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors Recruiting all versions